Page 1 of 1

Adding a Federation weapon to Rebel ships and stations

Posted: Sun Oct 25, 2009 10:17 pm
by BenG
How would I add a Federation-based weapon like a phaser to a Rebel ship or station, I'd like to add the MTPS from Admiral Fraser's mod and I've tried before but it wouldn't work. Something to do with the hardpoints maybe? Any suggestions?

Posted: Mon Nov 23, 2009 11:14 am
by KlingonMage
You wanna be more specific? What did you try? How did it fail? What did you try then?

To add weapon ot a ship, insert this into the ODF file

// prexisting weapon
weaponX = "weapon name goes here"
weaponHardpointsX = "hp01"

// your new weapon
weaponX+1 = "new weapon name here"
weaponHardpointsX+1 = "hp01" "hp02" "hp03" "hpN+1"

Hardpoints dont usually cause crahses, the weapon will just fail to fire, now this is assuming you placed it on a hardpont that exists. Ide reccomend against using hp88 and hp70.

Adding a Federation weapon to Rebel Ship or Station

Posted: Mon Nov 23, 2009 6:45 pm
by BenG
I tried the Multiple Phaser Targeting System from Admiral Fraser's Mod. I replaced one of the weapons with "MPTS" like it was in the phaser cannon from the original mod. It didn't crash the game but it just didn't fire. I thought it would be useful again because of the masses of TIE fighters the AI likes to build. I'll try it again and see what happens.

Hardpoints

Posted: Thu Dec 24, 2009 11:02 am
by BenG
BTW is there a program or something i can download that tells me how many hard-points are on a certain ship or station?

Posted: Mon Dec 28, 2009 8:23 pm
by AFC
http://www.unwrap3d.com/u3d/index.aspx

make sure you download plugin

works great but cant move hp in it