Star Trek Armada II - Requesting Modding Help & Crashing

The best Modding forum in the Armada community, some of the best modders come here.

Moderators: thunderchero, MrVulcan

Post Reply
User avatar
jetnova16
Ensign
Ensign
Posts: 408
Joined: Sat May 23, 2009 2:00 am
Location: NY State
Contact:

Star Trek Armada II - Requesting Modding Help & Crashing

Post by jetnova16 »

Star Trek Armada II - Requesting Modding Help & Crashing Errors Help – Thread 1

In this thread, I will be describing two different crashing errors. Each of the following threads in this part will continue with the other crashing errors in my Star Trek Armada II Mod. Each one will only list two crashing errors. The more important errors will appear in the first threads and then work their way up to the errors that I don’t think are as important but still are important in their own ways.

**********THE CRASHING ERRORS**********

1. This error started on 8/26/2010 when I added the mod this mod from Armada2Files, it is called Star Trek Armada II - Armada III (3) Concept Species 8472 1.0 and ever since installing this mod I was actually hoping to turn Species 8472 into an actual playable race by trying to make them as strong as the other races would be without that many additions since there really isn’t that much for them. Things though haven’t worked out to plan with wanting to do this. After I installed them to my game, I couldn't play Instant Action games anymore. Clicking on the Borg cube to get to the menu to set up an Instant Action game would actually crash the game. I removed Species 8472 from my races.odf file and guess what, I was able to get to the Instant Action menu without a crash and I could even get into an Instant Action game until my Trading Stations error for all races kicked in and crashed the game because the AI built a Trading Station. Well that isn't the problem I'm coming to you about. I added your mod to the game because I wanted to play as Species 8472 in Instant Action because of the crashing error that your mod is causing I can't even start an Instant Action game. I’m not sure if Vanilla Ultimate might be causing this because the mod said to install it to an unmodded Armada II install, but who really now a days has an unmodded Armada II install or wouldn’t be actually creating a mod using them? Well this error isn’t just limited to Species 8472 because every other race that I add to the game after race10 (The Dominion in my mod) doesn’t show up in the game’s Instant Action menu, but Species 8472 is the only race even preventing getting to the Instant Action setup menu because the game crashes the moment the Borg Cube is clicked on.

2. This actually ties in and was started in Error # 1. As stated the races added to Star Trek Armada II after Race # 9 don’t show up in the Instant Action Menu at all. I know Star Trek Armada I was designed to hold only 6 Races when modded but Star Trek Armada II was designed to hold 13. In a mod that I’ve played that I happen to know works just fine, there was a race.odf file that looked like this:
numberOfRaces = 14
race0 = "borg.odf"
race1 = "fed.odf"
race2 = "kling.odf"
race3 = "rom.odf"
race4 = "card.odf"
race5 = "fer.odf"
race6 = "species8472.odf"
race7 = "dominion.odf"
race8 = "breen.odf"
race9 = "rebel.odf"
race10 = "empire.odf"
race11 = "Andromeda.odf"
race12 = "maquis.odf"
// this one is 'uninhabited' for planets
race13 = "norace.odf"

Now, this is what my race.odf file looks like right now and it doesn’t have the other races after # 9 (The Dominion) showing up in Instant Action at all:
numberOfRaces = 14
race0 = "borg.odf"
race1 = "fed.odf"
race2 = "kling.odf"
race3 = "rom.odf"
race4 = "card.odf"
race5 = "tholian.odf"
race6 = "reman.odf"
// this for a certain reman special weapon
race7 = "terran.odf"
race8 = "vulcan.odf"
race9 = "dominion.odf"
race10 = "sona"
race11 = “gorn”
race12 = "species8472.odf"
// this one is 'uninhabited' for planets
race13= "norace.odf"
Last edited by jetnova16 on Fri Sep 10, 2010 12:20 am, edited 1 time in total.
User avatar
shadow
Cadet 4th Year
Cadet 4th Year
Posts: 125
Joined: Sat Apr 26, 2003 2:00 am

Post by shadow »

Just look at the lines of your coding an the mistake is obvious.

You wrote:

race10 = "sona"
race11 = “gorn”


instead it should read:

race10 = "sona.odf"
race11 = “gorn.odf”

Armada 2 stops to display your race list at race9 because the following referrals are not correct. So it stops there.
User avatar
jetnova16
Ensign
Ensign
Posts: 408
Joined: Sat May 23, 2009 2:00 am
Location: NY State
Contact:

Post by jetnova16 »

shadow wrote:Just look at the lines of your coding an the mistake is obvious.

You wrote:

race10 = "sona"
race11 = “gorn”


instead it should read:

race10 = "sona.odf"
race11 = “gorn.odf”

Armada 2 stops to display your race list at race9 because the following referrals are not correct. So it stops there.
That was actually the only way to prevent the Son'a and the Gorn from pulling the same type of crashing error that is also happening with Species 8472,
These races still don't show up in the Instant Action race selection and when they have the .odf part added to their name in the races.odf file, the game keeps crashing before even being able to set up an Instant Action game, when they are removed from the race.odf file (commented out, or the .odf part is removed) the game doesn't crash when clicking on the Borg Cube and setting up an Instant Action game.

How do you explain this? I would think that the game is either programmed to not go over 9 races or there is a file that is labled wrong somewhere in the main game directory governing the number of races and is some how only allowing 9 playable races and then "norace.odf". But why?
User avatar
jetnova16
Ensign
Ensign
Posts: 408
Joined: Sat May 23, 2009 2:00 am
Location: NY State
Contact:

Species 8472

Post by jetnova16 »

I ran a few more tests with the crashing problem involving Species 8472, I subtracted some of the units in their standard units slots in species8472.odf and now they don't crash the game when trying to use the Map Editor with them as a playable race, but they still cause the crash when clicking on the Borg Cube to even try and set up an Instant Action Game.

As I previously stated, this problem only started occurring right after adding the Armada 3 Concept Mod Species 8472. The ships that are extra from this mod actually work and show up in the Map Editor when set onto a map. I still don't know why Species 8472 is causing this error or why it starts with them, but any race after race 9 (The Dominion) seem to cause the game to crash whenever trying to set up an Instant Action Game.
I do believe that this error is also interfering with the Campaign though because some of the Federation missions that feature Species 8472 crash the Map Editor before I can even get to the map, the same happens for the Klingon and Borg Campaigns.

This is all I can report on this error because this is all I can find out about it. I was going to remove the Armada 3 Concept Mod Species 8472 but if the extra ships from it can work in the Map Editor after subtracting out a few of the races Standard Units, it just can't be the problem even though the crashing error started after adding them. Given this information, does anyone know why this could be happening?
User avatar
MrVulcan
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 660
Joined: Fri Apr 25, 2003 2:00 am
Location: TO CA

Post by MrVulcan »

Each ship and station has this line someplace

Code: Select all

race = "" 
If that race doesn't exist in the races.odf file (of if the corresponding race odf file doesn't exist), then you'd get these types of crashes. Make sure that the Armada 3 concept mod didn't change the races names or interfere in some way with the 8472 race odf.

Definately not a ship or station odf problem though if all units of that race are causing the crash.

Good luck
User avatar
jetnova16
Ensign
Ensign
Posts: 408
Joined: Sat May 23, 2009 2:00 am
Location: NY State
Contact:

Post by jetnova16 »

MrVulcan wrote:Each ship and station has this line someplace

Code: Select all

race = "" 
If that race doesn't exist in the races.odf file (of if the corresponding race odf file doesn't exist), then you'd get these types of crashes. Make sure that the Armada 3 concept mod didn't change the races names or interfere in some way with the 8472 race odf.

Definately not a ship or station odf problem though if all units of that race are causing the crash.

Good luck

I'll check again, but I thought I might have done that already, the race file itself was never edited by the mod, because the dates were the same when I overrote the file.
User avatar
jetnova16
Ensign
Ensign
Posts: 408
Joined: Sat May 23, 2009 2:00 am
Location: NY State
Contact:

Post by jetnova16 »

MrVulcan wrote:Each ship and station has this line someplace

Code: Select all

race = "" 
If that race doesn't exist in the races.odf file (of if the corresponding race odf file doesn't exist), then you'd get these types of crashes. Make sure that the Armada 3 concept mod didn't change the races names or interfere in some way with the 8472 race odf.

Definately not a ship or station odf problem though if all units of that race are causing the crash.

Good luck

I found out what was actually causing Species 8472, the Sona and the Gorn to crash the game, it wasn't the Armada 3 Concept Mod Species 8472, the Sona race or even the Gorn. In fact, I've gotten all these races to finally appear in the game. The problem was actually all realtated to the Sona and not the other two races. The Son'a seem to have a problem with their weapons, I commented out all their standard units except the 2 construction ships and the game loaded and also allowed me to set up an Instant Action game.

After getting the Son'a to work (still need to fix the weapons, might give them Dominion weapons) ,but I moved on to the Gorn and also commented out their main standard units just in case and the game still didn't crash. Did the same wtih Species 8472 and there also wasn't a crash. I believe this part of the described probelm for this thread is now officially fixed.

(I happend to come up with this fix just by running a small test, that all it was that lead t oit, but at least it worked.)
User avatar
jetnova16
Ensign
Ensign
Posts: 408
Joined: Sat May 23, 2009 2:00 am
Location: NY State
Contact:

Post by jetnova16 »

I just wanted to report that all of my crashing errors have been solved! They were all related to one problem and that was the Ferengi in the Race File. Their name had been changed by a mod and I didn't notice it I fixed the ODF file for the Ferengi to = the full version of their name and all errors were fixed.

All errors confused everyone for along time even me but were easily fixed.

I'm surprised that well I was a member at Armada2Files and MSFC that no one found the errors, but then again on both those sites I was told that the Patch Project 1.2.5 Patch wouldn't work with Vanilla Ultimate. Turns out it does work and the feature that alloes for sending or copying Error Reports helped solve all of these problems as the Fleet Ops Forums.

I like to thank those who offered their help here too, it was really appreciated.

My new question involves combingin two races into one as an Alliance without lossing the individual races sounds. Can this be done and how?

Also I was wondering if anyone can help me turn some Federation, Klingon-Cardassian ships and stations into ones from the Mirror Universe to create teh Terran Empire an the Klingon-Cardassian Alliance?
Post Reply