Page 1 of 1

Trouble getting buttons to show up!

Posted: Sun Apr 12, 2009 2:31 pm
by avien
Ok So I'm pretty new to modding... discovered it only about 2 weeks ago.

Anyway, I discovered Armada 2 files and Armada Fleet Command and just went nuts downloading a bunch of different ships and stuff, I can add them to the game no problem. Where I keep hitting a block is getting the buttons to show up in the build menu

as an example I downloaded the NX Class from Enterprise, by Deemon (correct my spelling if its wrong) which is super cool. It didn't come with a build button, so I made one myself using Westworlds BBOM as a guide and named it gbfnx (64pixels x 64 pixels) and saved it as a .tga file.

So I have a .SOD and .odf called fnx and a button called gbfnx all saved in the appropriate folders (SOD-ships, ODF-ships, textures-RGB respectively)
and I edited the techtree and gui to include the ship and wire frame, all of which work beautifully...except the button is just a blank white/grey square, this happens for all customised buttons.


I updated the global_gui with the following under the section

# Federation build buttons

b_fnx gbfnx 0 0 64 64

The only thing that seems to be different is the file size. All the others are 12kb even but my button is 12.3kb, I tried using a plain black background which reduced the size to 5kb and this also didn't help. With a lot of effort I managed to get the file to exactly 12kb.... BUT it still wont work.... I eventually found a button pack with the NX in it by Klingon on this site... but alas, even this did not work.

The thing thats really irritating me is that I have tried using the button for fscout and fbattle etc and it will show them just fine, so to me it seems like it must be a problem with the image itself.

If anyone could tell me where I'm going wrong I will literally love that person (but hopefully not in a scary way!)

Thanks in advance - let me know if you need any additional info...

Posted: Sun Apr 12, 2009 8:09 pm
by MrVulcan
Hi avien, welcome to the site :)

The button is probably not showing up because it is a compressed tga image (which also explains the different file size). When saving tgas, make sure that compression options are turned off. Some programs call this RLE Compression. Either way, make sure the tga is uncompressed.

Hope this helps.

Posted: Mon Apr 13, 2009 4:02 am
by avien
OMG I can't believe its that simple!!! How did I miss that?!!!

That worked!

thanks Mr Vulcan - you rock!

Posted: Mon Apr 13, 2009 4:21 am
by steviegirl
Good luck!

Posted: Tue Apr 14, 2009 4:22 pm
by pepperman
yes avien, welcome to the site. good to see new modders join the scene.