Page 1 of 1

game crashes when combining elements of two mods

Posted: Thu Apr 23, 2009 6:00 pm
by BenG
I'm new to modding. I have Admiral Fraser's mod and a Star Wars mod that adds ships and one station to the game. Fraser's mod is not installed on the game itself it is in a separate folder. I took the odfs for the federation phaser turret and the multiple phaser targeting system and put them in the add-on folder of the Root directory. I built the turret but as soon as it completed the game crashed. please help. would be very useful against the masses of TIE fighters.

Posted: Thu Apr 23, 2009 7:13 pm
by MrVulcan
Hi BenG, welcome to the forums.

It could be a problem with the weapon's odf or the phaser turret weapon entries. Make sure there are no typos in either of these. Also mke sure that the weapon number and the weaponHardpoints number are the same, and that the hp's are not missing any quotation marks.

Post the odfs, will be much easier to tell what's causing this.

game crashes when combining elements of two mods

Posted: Thu Apr 23, 2009 8:14 pm
by BenG
Thanks here is the odf for the turret itself.
#include "turret.odf"
unitName = "Phaser Turret"
tooltip = "Phaser Turret"
verboseTooltip = "Primary Base Defense upgraded with the Multiple Phaser Targeting System"
race = "federation"
buildTime = 17.5
officerCost = 1
dilithiumCost = 150
maxHealth = 1000
shieldRate = 5.0
attackPower = 0.50f
intrinsicValue = 0.50f
weaponsHitPoints = 1
weapon1 = "mpts"
weaponHardpoints1 = "hp01" "hp02"
enginesTargetHardpoints = "hp10" "hp11" "hp12" "hp13"
lifeSupportTargetHardpoints = "hp10" "hp11" "hp12" "hp13"
weaponsTargetHardpoints = "hp10" "hp11" "hp12" "hp13"
shieldGeneratorTargetHardpoints = "hp10" "hp11" "hp12" "hp13"
sensorsTargetHardpoints = "hp10" "hp11" "hp12" "hp13"
hullTargetHardpoints = "hp10" "hp11" "hp12" "hp13"
criticalTargetHardpoints = "hp10" "hp11" "hp12" "hp13"
eventSelect = "PhaserTurretSelect"
eventAcknowledge = "PhaserTurretAcknowledge"
eventAttack = "PhaserTurretAttack"
eventDecommission = "PhaserTurretDecommission"
keymapLabel = "phaser_turret"
scaleSOD = 0.4

game crashes when combining elements of two mods

Posted: Thu Apr 23, 2009 8:16 pm
by BenG
Here's the odf for the weapon itself. #include "fphaser.odf"
wpnName = "MPTS"
tooltip = "Multiple Phaser Targeting System - Prometheus"
verboseTooltip = "A weapon system that allows existing phaser banks to lock on to multiple targets."
ordName = "fphasero"
buttonSlot = 0
special = 0
maxTargets = 8
shotDelay = 1.6
range = 500.0f
switchToAttack = 1
classLabel = "areacannon"
wpnReticle = "gblast"
wpnPriority = 0
wpnCategory = "ARCA"
hitCondition = 2

game crashes when combining elements of two mods

Posted: Thu Apr 23, 2009 8:19 pm
by BenG
Thanks again, I didn't change anything in the odf itself. I just copied and pasted both items to the add-on folder of the Armada root directory. I also tried to get his Defiant Variant on there too. Whenever I built it the same problem occurred.

Posted: Fri Apr 24, 2009 4:14 pm
by pepperman
ensure that the mpts.odf file is in the addon folder.

ensure that the base file fphaser.odf is in the odf folder

ensure that the ord file fphasero.odf is in the odf file

ensure that the sprite called with the fphasero.odf is in the weapons.spr file

Posted: Sat Apr 25, 2009 1:33 pm
by steviegirl
Also keep in mind that A1 files(most of them),go in the addon folder.A2,you need to put the files in coresponding folders...or....your ship might not work!Also.....A2 you need to edit the gui global sprite,weapon sprite,and tech tree files to get the darn thing ta' build!

GOOD JOURNY!

works ok now

Posted: Tue Jun 30, 2009 9:02 am
by BenG
Thanks for the tips, I tried it again last night and it works but I've encountered a rather unusual problem. When I play as the Federation against the Empire, I build up my fleet and start to attack their bases but when I use one or two Temporal Research facilities against the enemy, about half-way into my attack the game crashes. Now I can attack without the Research Facility and win just fine. So I'm just wondering about it.

Posted: Wed Jul 01, 2009 6:23 pm
by MrVulcan
Does this happen when you use the temporal weapon? Or just when you have the temporal research station built? Try using the temporal weapon on an empty area with no enemy ships nearby. Wait until the temporal distortion elapses. If this causes the game to crash, you'll know precisely what caused it.

If you can build the station just fine and don't use the temporal weapon, but the game still crashes during sometime while you're attaching the enemy, the problem is most likely not related to the temporal research station.

See if you can narrow down the problem area to a few possible odfs. Then run a debugger such as the STAUM mod debugger availible in the modding tools section. That might be able to tell you what's broken or missing.

game crashes when using temp.

Posted: Wed Jul 01, 2009 8:02 pm
by BenG
Thanks for the tip, it crashes when i use the station on enemy ships, I also use more than one (one or two so far haven't been able to use more than two before it crashes) since the enemy base is usually bigger than the radius of the stasis field, could I be using too many at one time?

no save game option

Posted: Thu Jul 23, 2009 8:10 pm
by BenG
another unusual thing is that i don't get a save game option with the star wars vs star trek mod, now there is an update to v1.02 and I've had the mod on before but i uninstalled it and reinstalled it and its patches but i don't have the save game option is there a way to make a save game option?

Posted: Mon Jul 27, 2009 8:32 am
by Elrond
It can also be that non-standard double-quotes are used somewhere (other than the standard " quotes). If that's the case, I could see that causing crashes.

game crashes when using two mods

Posted: Mon Jul 27, 2009 9:41 am
by BenG
thanks actually i figured everything out. I was using a no-cd .exe to run the program and it probably made it unstable. Once I started playing with the CD it ran just fine. Thats also why I couldn't save any games without the cd. Anyways thanks for all your help guys.