Command Cruiser not appearing in Build List

Ultimate Editor; support/discussion/questions

Moderator: thunderchero

Post Reply
User avatar
popikoff
Cadet 1st Year
Cadet 1st Year
Posts: 3
Joined: Sat Dec 06, 2008 3:00 am

Command Cruiser not appearing in Build List

Post by popikoff » Sat Nov 29, 2014 5:35 pm

Hi all,

I've got a glitch on a single player game. It's using the All of the Ages mod, and I have tweaked maintenance, production costs, torpedo, and phaser strengths on all races using Ultimate Editor.

The glitch is that I should now be able to build a Ambassador class Command Cruiser. But it does not appear in my build list!

Any ideas on what might have caused this problem and how it can be prevented/fixed? I am unsure if this is related to the mod, UE, or anything else.

I've searched the forums, but couldn't find an answer.

Thanks! :)

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6066
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Command Cruiser not appearing in Build List

Post by thunderchero » Sat Nov 29, 2014 6:30 pm

IIRC this is due to the shiplist order/upgrade error.

example if an upgrade of a ship is above the ship it upgrades ship will not show of build list.

thunderchero

User avatar
popikoff
Cadet 1st Year
Cadet 1st Year
Posts: 3
Joined: Sat Dec 06, 2008 3:00 am

Re: Command Cruiser not appearing in Build List

Post by popikoff » Sun Nov 30, 2014 1:21 pm

Hi again,

I've reordered the ship list and that seems to have fixed the problem. They were all in a jumbled order, always have been since I installed this mod. I didn't realise the order mattered that much. Now I have placed them in upgrade order I, II, III and so on.

The added bonus is that the build list is much tidier. I had all the old ships still in there, which had been upgraded already. amd obviously I no longer built them. However, the build list is not in alphabetical order, and what I wonder what would happen if I put it in order?...

Thanks very much for your help! :grin:

Just one last question: any idea what "Production" is in the ship stats? All ships have it set to zero except for the Colony and Troop ships. Again, I've tried looking it up, but "production" is not the best search term!

User avatar
adi
Commander
Commander
Posts: 442
Joined: Sun Aug 12, 2012 6:53 pm
Location: US East Coast

Re: Command Cruiser not appearing in Build List

Post by adi » Sun Nov 30, 2014 6:09 pm

Production for Transports(TTs) is how much they build in a turn towards an outpost; a 1000 production cost outpost will be built by a 200 production transport in 5 turns; or by 5 TTs in one turn. Also production in TTS determines the ground attack of the TTs.
For colony ships the production value is the index in a table that sets how much they terraform in one turn and what buildings you get when colonizing. Mods have different such tables.

Ordering the ships in the ship list is important for AI too; the AI decides what kind of ship (scout, destroyer, cruiser etc.) to build next and builds the first one of that kind from the list; so if you put the low tech cruisers above of the higher tech ones, when deciding to build a cruiser it will keep building the old, low tech version.

So use this pattern:
highTechCruiser
highTechCruiserUpGrage
highTechCruiserUpGrade2
lowTechCruiser
lowTechCruiserUpGrade
lowTechCruiserUpGrade2

as a tip, since the in-game ship list is ordered alphabetically, i like to name the top tech ships like Adv. Cruiser, Adv. Destroyes, so at end game they are always at the top of the list. No scrolling.

User avatar
popikoff
Cadet 1st Year
Cadet 1st Year
Posts: 3
Joined: Sat Dec 06, 2008 3:00 am

Re: Command Cruiser not appearing in Build List

Post by popikoff » Wed Dec 24, 2014 7:29 pm

Hello adi,

Sorry for the late reply. Many thanks for that information and the tip. I will tweak the shiplist accordingly. Have a great festive season!

Post Reply

Return to “Ultimate Editor”

Who is online

Users browsing this forum: No registered users