HELP!! unknow gui crash

This forum contains threads from main General Chat forum older than 3 months.

Moderator: thunderchero

Post Reply
User avatar
Peter1981
Rear-Admiral
Rear-Admiral
Posts: 1118
Joined: Tue May 06, 2008 2:00 am
Location: England

HELP!! unknow gui crash

Post by Peter1981 » Wed Nov 16, 2011 5:56 am

On loading any of the races in the tos mod i get the following

=====================================================
ST:BOF Tue Sep 6 18:42:18 2011

Version Under Test: 72
File: guifile.c, Line: 468,
Initialize State: 31
Player Empire: 1 Starting Seed: 1315330933
Galaxy shape: 0 Galaxy Size: 2
=====================================================

Old saves will load fine but crash on turn processing -- new games won't start,the only recent changes are increased shipnames (using UE AFAIK not the problem), added a few minor ships (again seems to be working) -- please can any one shed any light on this else the TOS mod won't be ready for Xmas :(

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Re: HELP!! unknow gui crash

Post by Flocke » Wed Nov 16, 2011 6:13 am

that error comes from GUIFile_547490 (5474AF)
sure you didn't modify something gui related?

Edit: If you debug it, you can determine the exact gui file that's loading wrong. ;)

User avatar
Peter1981
Rear-Admiral
Rear-Admiral
Posts: 1118
Joined: Tue May 06, 2008 2:00 am
Location: England

Re: HELP!! unknow gui crash

Post by Peter1981 » Wed Nov 16, 2011 9:02 am

seem the shipname.bin file was deleted (maybe by UE?) have installed a backup so am testing... this would cause a gui crash i suppose if a ship name didn't exist??

that seems to have done the trick! :D

User avatar
Tethys
Past Administrator
Past Administrator
Posts: 2065
Joined: Fri Jul 18, 2008 2:00 am
Location: Your mom's bed ;)
Contact:

Re: HELP!! unknow gui crash

Post by Tethys » Wed Nov 16, 2011 11:56 am

Interesting.. Ive had my stbof.ini file deleted a few times (as if I opened the file, deleted the contents, and resaved it). This scares the crap out of me because it crashes trek.exe starting up the game :O
Not for the weak of heart...
Image
GALM <--- GALM/Galaxies Mod

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Re: HELP!! unknow gui crash

Post by Flocke » Wed Nov 16, 2011 12:07 pm

great you solved it Peter :)

Post Reply

Return to “General Chat Archive”

Who is online

Users browsing this forum: No registered users