Page 1 of 1

windows 7 appcrash ntdll.dll

Posted: Sun Oct 30, 2011 9:57 am
by Brett

Don't know if anyone can help me here? I've loved this game (BOTF) since the year of it's release. As the genuine Disc version didn't work I use the download, lastest version.

I am running:

Window 7 Ultimate 64
Asus Pt6d M/Bd
2 x Msi Nvidia 470's GPU's ( I run in single for the game)
I7 950
20 Gb Corsair RAM

Game has run well for ages but am suddenly getting the following error and game crashes out:

Faulting Application Path: F:\BOTF\trek.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: trek.exe
Application Version:
Application Timestamp: 37965563
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.17514
Fault Module Timestamp: 4ce7ba58
Exception Code: c0000008
Exception Offset: 00082865
OS Version: 6.1.7601.
Locale ID: 2057
Additional Information 1: d0f5
Additional Information 2: d0f5261df562d6396e04e3d7ecb3c6f6
Additional Information 3: 478f
Additional Information 4: 478f548fff792653d907239bb2df8508

I also developed several other errors including DEP, now sorted and new Kaspersky 2012, have told Kaspersky that Trek.Exe is trusted and that seems taken care of but the error for whom I have shown the log I just cannot overcome.

Any constructive ideas would be most welcome.

Keep up the great work.

Re: windows 7 appcrash ntdll.dll

Posted: Sun Oct 30, 2011 11:02 am
by thunderchero
Welcome Brett,

I have never seen this type of problem, but will suggest if you downloaded the iso version you should try the multi installer version it is more compatable. ... load&cid=9


Re: windows 7 appcrash ntdll.dll

Posted: Mon Oct 31, 2011 4:05 pm
by KrazeeXXL
I had some issues regarding Antivirus Software Updates in the last couple of weeks. So it seems to be a good guess that this error is related to that.

Kaspersky 2012 might have some new features in segments like heuristics or other stuff which might come into play and crash BotF.

According to ... dlldll.htm ntdll.dll crashs can have various reasons.

Point 8 on this list seems interesting to me as you wrote you have 20GB of RAM installed. (a lot of modules)

So, I suggest testing them with memtest86+.

Just to be sure. If you can't trust your RAM, you can't trust your PC.

Re: windows 7 appcrash ntdll.dll

Posted: Thu Nov 03, 2011 7:01 pm
by Brett
Thanks for the help gents, I'll run memtest, RAM is in 5 x 4Gb modules but seems stable in all other applications.

Re: windows 7 appcrash ntdll.dll

Posted: Thu Nov 03, 2011 7:13 pm
by Tethys
20 gb, lol, what are you running 20x Photoshop CS and 2x Crysis on highest settings? Or is it just for BotF ;)

Re: windows 7 appcrash ntdll.dll

Posted: Tue Oct 09, 2012 5:32 pm
by Flocke
Old topic, I know, but testing mpr++ on my new laptop with windows8 pro 64bit 8gb I encounter same problem:
Problemereignisname: APPCRASH
Anwendungsname: trek.exe
Anwendungszeitstempel: 37965563
Fehlermodulname: ntdll.dll
Fehlermodulversion: 6.2.9200.16384
Fehlermodulzeitstempel: 5010ae7a
Ausnahmecode: c0000008
Ausnahmeoffset: 0007b921
Betriebsystemversion: 6.2.9200.
Gebietsschema-ID: 1031
Zusatzinformation 1: cf09
Zusatzinformation 2: cf09974bf4f4cc68217ade05b74c8d06
Zusatzinformation 3: 9e43
Zusatzinformation 4: 9e4388df4491c065736277f5f6a6ef71
Edit: Strange but though I've encountered almost same error mine seems to be caused by mpr++ not released when this topic started. :?

Crash log empty ofc.

Interestingly it only happens under certain circumstances I'm not aware of yet.
E.g. with udm mod playing the dominion it always happens when you play a battle and afterwards switch to research screen and select ship database first time but not when you already went to ship database before of a combat.
I dunno what further circumstances there are, but as it's very reproducable I hope a solution can be found.
So long just an issue to keep in mind if not anyone interested to investigate this bug.
Playing federation or vanilla botf I didn't notice this bug yet but didn't test much. :roll:

Re: windows 7 appcrash ntdll.dll

Posted: Sat Dec 29, 2012 7:35 am
by Flocke
I still have this error on my list but will not continue to investigate it. I guess thunderchero was right in telling me it's a system or driver related issue I have... :roll:
It only happens with mpr++ when old mpr render mode is activated AND old vanilla hobs are used.
As with new replacement hobs I don't encounter it anymore and old render mode is subject to be replaced in some time too, I think I better just forget on it.

I checked all mpr+ code and packages I get from botf and found no error there but it seemed eventually related to lighting animations of old hobs on outposts and starbases.
When I viewed federation outpost in research screen (vanilla), 2nd time I viewed it, it mostly crashed.
I just want to print that down in case me or someone stumbles upon it again.