Pre-requisites for the game to run

Supremacy; support/discussion/questions

Moderators: thunderchero, Iceman

Post Reply
Iceman
Commodore
Commodore
Posts: 838
Joined: Fri Apr 10, 2009 2:00 am

Pre-requisites for the game to run

Post by Iceman » Wed Jun 03, 2015 5:35 am

- DirectX 9 or higher

- DirectX 9-compatible video card with Pixel Shader 2.0+ and Vertex Shader 1.1+ support

- Desktop resolution of at least 1024x768 (1280x768 or higher is strongly recommended)


- Microsoft DirectX Runtime

- Microsoft XNA Framework 3.1 Redistributable

- Microsoft .NET Framework 3.5 SP1

- Microsoft .NET Framework 4.5.1
(note: you want the full framework, not the "Client Profile"; after it's installed, you should see both the "Client Profile" and "Extended Profile" listed in your control panel. Also note that the latest version of .Net is 4.5, and future game versions *might* need the more recent versions)


For builds prior to SupremacyTest_20190517, also:

- Microsoft Visual C++ 2008 Redistributable

- Microsoft Visual C++ 2010 Redistributable

User avatar
Coracle
Cadet 4th Year
Cadet 4th Year
Posts: 19
Joined: Sat Jul 24, 2010 2:00 am

Re: Pre-requisites for the game to run

Post by Coracle » Tue Jan 03, 2017 10:38 am

Is .Net Framework 4.6.1 also o.k.?

User avatar
Valcoren
Lieutenant-Commander
Lieutenant-Commander
Posts: 107
Joined: Wed Dec 31, 2008 3:00 am

Re: Pre-requisites for the game to run

Post by Valcoren » Sun Jan 08, 2017 3:20 pm

Coracle wrote:Is .Net Framework 4.6.1 also o.k.?
Hi Coracle, this should be ok.

Post Reply

Return to “Supremacy”

Who is online

Users browsing this forum: Google [Bot]