Page 2 of 2

Re: Weird hang - geordie

Posted: Thu Oct 28, 2021 4:45 pm
by Iceman
Had no problems today. Here's the save, 1 turn later. Gave some orders.

Noticed another one of those minors with an excessive energy cost for a research building, the Ventaxians. Fixed.

Re: Weird hang - geordie

Posted: Thu Oct 28, 2021 6:11 pm
by geordie
OK. I decided to try that despite some cost (or time) - I have reinstalled Win 10 to its initial settings.

And I got that error exactly in the same moment - buying the Moon Habitation in the Zuben Elakrab system. :(

So at least no ghosts or haunted system anymore :)

Yea, I remembered about the Ventaxians, at least they had quite nice research output.

Re: Weird hang - geordie

Posted: Fri Oct 29, 2021 10:47 am
by Iceman
In that save I attached yesterday, I bought the MoonHab and there were no errors.
This error, is it the game hanging again, or is there an error log?

Re: Weird hang - geordie

Posted: Sat Oct 30, 2021 3:08 pm
by geordie
No log.
I tried today again with a new patch and I have that hang itrying to buy the Moon Habitation in the Zuben Elakrab system or if I do it as a first operation I get it after reviewing the SItReps and exactly in an attemp to swicth to the Colonies Screen. Exactly the same was before and after the WIndows reset.
I give up. I will try your save - thanks pretty much :up: . But I was interested in a reason of at least a hint of that problem more. Maybe I would start a new game...

Re: Weird hang - geordie

Posted: Sat Oct 30, 2021 4:23 pm
by Iceman
geordie wrote: Sat Oct 30, 2021 3:08 pm I give up. I will try your save - thanks pretty much :up: . But I was interested in a reason of at least a hint of that problem more.
Tried again to replicate what you explained, but I managed to end turn just fine.

Maybe I would start a new game...
Given the new fixes, it might be a good idea.
I just started a new one too.

Re: Weird hang - geordie

Posted: Wed Nov 24, 2021 5:29 pm
by geordie
And I got that hang again....
Windows back to stating setup, new game, turn 291, 157 star systems owned + 20 minor members and all the same symptoms. A long list of upgrated systems be newly achieved building updates.
:(

Re: Weird hang - geordie

Posted: Thu Nov 25, 2021 7:57 am
by geordie
I was able to play 2 turns avoiding places causing the hang, using pop-up system list or keyboard shortcuts. But the last autosave is corrupted and cannot progress anymore.
.autosav.zip
(710.86 KiB) Downloaded 5 times
I have attached it, maybe you are able to find a trace of the problem. I have 2 last saves as well.
I tried a fresh installation as well, with exactly the same effect. The game creates autosave, but next turn process is not completed. It is not related to overloaded computer - a usage was 13% of CPU and 1GB RAM.

Re: Weird hang - geordie

Posted: Thu Nov 25, 2021 6:50 pm
by Iceman
I can't load this autosave...

Re: Weird hang - geordie

Posted: Thu Nov 25, 2021 7:01 pm
by geordie
Thanks anyway. I thought that even if corrupted it could put some light on the problem....
Here is a save one turn earlier:
SP Klingons Huge Irregular 292.zip
(710.15 KiB) Downloaded 5 times
In fact, for some time, I cannot advance any game more than, let's say, 60% and it becomes unplayable :(

Re: Weird hang - geordie

Posted: Fri Nov 26, 2021 5:00 pm
by Iceman
It seems to be the same problem as before, the fragmented territory issue. I tried to alleviate the problem a bit more in the patchI'm uploading right now, but it might have to do with savegame size.
When you feel like trying a Large galaxy instead of Huge, it would be interesting to check if you run into the same problem.

Re: Weird hang - geordie

Posted: Sat Nov 27, 2021 10:02 am
by geordie
Hehe, I have started a new Cards game, before your reply and even more careful - as Medium :)
So far (turn 168) no problem, but the beginning was always smooth.

Re: Weird hang - geordie

Posted: Sat Nov 27, 2021 10:48 am
by Iceman
Hehe, that was radical :wink: