XP problems/solutions please post them here

This forum contains threads from support forum outdated or no longer neede.

Moderator: thunderchero

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6059
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

XP problems/solutions please post them here

Post by thunderchero » Tue May 13, 2008 2:01 am

---------------------------------------------------------------------------------------------------------------------
Summary of Solutions
---------------------------------------------------------------------------------------------------------------------

Use Multi installer (this has all patches part of installer)

install using "software" mode (direct3d has been problematic)

turning off morphological filtering and crossfire.

video driver/software note
you might need to setup a profile within your video settings for each install of botf (Nvidia contol panel or Catalyst Control Center), BOTF needs lower settings than default in some cases.

thunderchero
Last edited by thunderchero on Wed Apr 13, 2016 6:26 pm, edited 3 times in total.

toroca
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 94
Joined: Sat Apr 26, 2008 2:00 am

Re: XP problems/solutions please post them here

Post by toroca » Tue May 13, 2008 12:48 pm

Maybe these things need to be rewritten so they're clearer to people who weren't necessarily following the conversations? Anyway, here's a couple for ya.

Problem:
The game installs fine, but the patch (either official or fan-made) doesn't update the game properly, or causes it to be inoperable.
Solution:
Use Joker's unofficial patch for the English and German versions of the game on Win95, 98, ME, and XP. It is located here.

Problem:
When the game crashes, I can't exit it without turning off the computer.
Solution:
Try setting your taskbar to Auto-Hide before playing the game. If you experience a crash, move the mouse downward until the taskbar appears. Then right-click on BOTF and choose close from the menu that appears. If a window appears saying that the program is not responding, choose End Task.

User avatar
Rii
Cadet 1st Year
Cadet 1st Year
Posts: 3
Joined: Tue Sep 02, 2008 2:00 am

Post by Rii » Thu Sep 04, 2008 7:10 am

I've a new problem I think.

After a whole day of testing, modding, patching, re-installing and of course informing about the problems that botf inflicts on XP, my problem is still unsolved.

Description: When I start the game it changes only for a few seconds to black screen and then collapsing. The crash.log reports:

Version Under Test: 72
File: ..\..\source\sound\compress\rdvoice.c, Line: 59, _voiceIfp != NULL
Initialize State: 7
Player Empire: 1 Starting Seed: 0
Galaxy shape: 0 Galaxy Size: 0

I've read a lot of threads (in many forums), where it seems to be that the author has a similar problem.
Mostly unanswered I find some 'therapies' here, but all in all...

Before u answer with the standard protokoll or something i will list my efforts.

- installed on athlon with xp and on a laptop with the same os / problem seems to be the same
- checking compatibility modes and also colormodes and... i checked it all!
(and now..) - using the joker's patch on v. 1.00 and after crashing again on the 1.02 (furthermore without success you imagine)
- downloading all cracks (german, us, multi) i can get for both versions on gamecopyworld and lacking megagames / no one does solve the problem or in lieu taking the cd-ckeckback away.
- as i consider that my cd might be corrupted itselve, I began the download of the backup file on armadafleetcommand and installed it with deamon tools, but it raises the same issue.

Thats all for the moment, but I'am sure I've forgotten some scenes. I'am really tired, because people with similar problems seemed to crack it with methods, which doesn't work when i try.

When I reflect my post and having all my efforts at a glance, it seems to be a mysterious orgon-energy or some nerving gremlins who torpedo all rationality.
So I've allready contemlated u can't help me without further informations.

So, thanks beforehand to all who want to think or allready heard about this problem and offer me help.

User avatar
DCER
Code Master
Code Master
Posts: 683
Joined: Sat Apr 26, 2008 2:00 am

Post by DCER » Thu Sep 04, 2008 8:55 am

Haven't heard of this problem before, but have you tried running it with sound turned off?

Open stbof.ini and set these to 0:

MUSICVOLUME=0

FXVOLUME=0

VIDEOVOLUME=0

VOICEVOLUME=0


Also you can turn the movie off in case it has trouble with those:

MOVIEON=OFF

User avatar
Rii
Cadet 1st Year
Cadet 1st Year
Posts: 3
Joined: Tue Sep 02, 2008 2:00 am

Post by Rii » Thu Sep 04, 2008 3:12 pm

Tested and fails again. *Arggh*
Even so thanks for help.

hmm.. I see much potential in the ini file.
There some strange entries e.g.
DIRECT X NOT INSTALLED BY BOF

Could botf fit with newest directx? I'm sure it does, cause I've never read about this problem in other posts... But if theres a chance :? ..

User avatar
DCER
Code Master
Code Master
Posts: 683
Joined: Sat Apr 26, 2008 2:00 am

Post by DCER » Thu Sep 04, 2008 4:15 pm

It should work with newest direct x. I wouldn't install the old one.

You can also check if the language is set right in stbof.ini, sometimes it is set to german instead of english when you pick to install the english version.

Judging by the error description it seems to be an error when decompressing wav files from english.snd/german.snd. Do you have XP sp2, older or newer?

This is probably overkill, but wine can run botf without problems, and is also available for windows although I never tried to install or use it there so no idea how hard that is. If it's a problem with windows libraries wine comes with it's own set of those so you might not get this problem if running botf under wine.

EDIT: but multiplayer doesn't work under wine, at least I couldn't get it to work, I don't know if it can be done or not, but single player works

User avatar
Rii
Cadet 1st Year
Cadet 1st Year
Posts: 3
Joined: Tue Sep 02, 2008 2:00 am

Post by Rii » Fri Sep 05, 2008 6:30 am

Jeha!
Problem is finally solved and if not, it had to be today after your last post DCER! :wink:

As I browsed through the ini I recognized that the language setting was adjusted to be German. However the game was installed in english and I had only the english.snd in the game directory.
Changing entry 'German' to 'English' fails at the moment. But then I think "write it in BIG LETTERS" and you have tried anything you could, and if this doesn't fit you have to send BotF to the graveyard!
So I changed to 'ENGLISH' and TADA! I've never reckon with such a banal solution.

This problem is a closed chapter. Thanks for help DCER. Seems to be, that this forum had seen every complication before. :)

Mentat
Commander
Commander
Posts: 360
Joined: Sun May 04, 2008 2:00 am

Post by Mentat » Thu Oct 09, 2008 2:05 pm

I have quite a simple question, and thought I had seen a post about that issue some day, but I honestly wasn't able to find it again.

One could call it a minor quirk, since BOTF runs smoothly on my system. But I can't see any of the movies, they simply get skipped.

The ini setting for movies is on btw.

User avatar
liteview1701
Ensign
Ensign
Posts: 37
Joined: Thu Aug 28, 2008 2:00 am

I Have

Post by liteview1701 » Sat Oct 11, 2008 12:30 pm

i have the same problem to but only on vista the movies dont play for federation klingom romulan etc wich strange.

User avatar
Icejazz
Cadet 2nd Year
Cadet 2nd Year
Posts: 5
Joined: Wed Jan 07, 2009 3:00 am

Post by Icejazz » Wed Jan 07, 2009 7:14 pm

Hi all,
happy new year 09 !
Ok, simple problem, I have no FX sound !
Music are ok.
All sound files are ok in botf directory: sfx.snd and english.snd
Movies are ok. (they were KO after install, but I used the "joker" patch "Botf-102-W2K-XP-9x-English-German.exe" and now I can see movies).
I use XPsp2.
Actually it looks like my system cannot read the .snd files, like the movie problem, solved by the patch dll in Joker patch.


Any idea is welcome. Thank you guys.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6059
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Post by thunderchero » Wed Jan 07, 2009 8:20 pm

have you checked options to see if SFX sounds are on?

thunderchero

User avatar
Icejazz
Cadet 2nd Year
Cadet 2nd Year
Posts: 5
Joined: Wed Jan 07, 2009 3:00 am

Post by Icejazz » Thu Jan 08, 2009 4:18 am

Hi thunder,
yes SFX volume is max, voice vol. also max.
I tried to install the Multi_BOTF_1.0.2_English_German.rar but same issue.

This makes me think about the video codec "iccvid.dll" faulty with XPsp2, I have to find which codec file is responsible for sound decompression....
Is there a way to access sounds directly from inside file SFX.snd ?
Maybe if I can decompress this file and access an actual SFX sound, my system will tell me which codec is missing/faulty....

User avatar
DCER
Code Master
Code Master
Posts: 683
Joined: Sat Apr 26, 2008 2:00 am

Post by DCER » Thu Jan 08, 2009 4:28 am

You can open sfx.snd with Ultimate Editor and extract the sounds. it should even be able to play the sounds for you.

User avatar
Icejazz
Cadet 2nd Year
Cadet 2nd Year
Posts: 5
Joined: Wed Jan 07, 2009 3:00 am

Post by Icejazz » Thu Jan 08, 2009 4:52 am

Yes hello DCER, thank you.
I was just playing with the tool Ultimate Editor (*very* nice job btw), and I could extract all the SFX files from SFX.snd
I can read properly all the 162 resulting .wav files.
(The same for the voice files)

So now I think I could again use your knowledge about what you used to extract files from the .snd in UE. Is it some sort of zip file ?
I think I need to know what does this job in Windows, and replace the faulty file. What do you think ?

EDIT: ah, DCER, another information that may help you... to help me ! :)
The "play" button in UE is silent.
I mean if I select a 2s sfx file, and I click the play button, I hear nothing, but the "play" button is greyed out for the 2s. Exactly as if the program was reading the file, but with no sound. It may be the same problem I have inside the game.
But if I extact the file, then I can read it (and hear it) using the media player.
So new question: what is used in UE to play sound files ?

User avatar
DCER
Code Master
Code Master
Posts: 683
Joined: Sat Apr 26, 2008 2:00 am

Post by DCER » Thu Jan 08, 2009 5:14 am

It's a custom botf file with a table and the wav files. Sort of like an archive except there's no compression. I think Joker would be better suited to help here, he was the one that fixed the movies after all. When it comes to windows and dll's I'm at a loss :)

The three wav files (extracted from english, sfx and music) are all different btw. Don't remember the specifics, the music ones are stereo I think. If you open them in a sound editor, it'll probably show the wav info somewhere.

Post Reply

Return to “Support Archive”

Who is online

Users browsing this forum: No registered users