Page 6 of 9

Re: Windows 10 problems/solutions please post them here

Posted: Tue Apr 26, 2016 2:00 pm
by thunderchero
Thats great news but did not help solve nvdia issues some users are having. (not your fault) and thanks for posting.

as for Dxwnd you could try it's own compatibility setting.

remove TS dlls
turn off trek.exe compatibility setting (in my test, game would not even load at all with it set in trek.exe)
open Dxwnd and select BOTF then right click and select modify.
in compatibility tab set as shown below
compat.jpg
compat.jpg (213.08 KiB) Viewed 3787 times
BTW using fake version in Dxwnd still works on my system

Re: Windows 10 problems/solutions please post them here

Posted: Tue Apr 26, 2016 2:21 pm
by alexgophermix
Very confused but disabling all compatibility settings on the trek.exe suddenly made the game work, even in windowed mode when using dxwnd. I had to remove the TS dll fixed files for this to work as you suggested and it starts instantly now instead of after a long delay

I'm almost certain using dxwnd was the first thing I tried (before addings TS dll files) but I've tried so many iterations maybe the simplest one was the one I forgot to do...

For reference this is what my Compat tab looks like in dxwnd. It seems the game works with or without the settings I had prefilled when I first started dxwnd.
Clipboard01.jpg
Clipboard01.jpg (32.81 KiB) Viewed 3786 times
Actually, out of curiosity I just tried starting the game without any compatibility settings OR TS dll files OR dxwnd and that worked as well. I know for certain that I tried that already. I must have had some latent settings files still on my computer from the previous install that were reset/corrected when the game finally started properly in the post above. Very strange.

I noticed that all the sound was set to 0 when the game first successfully started so I changed that back. I also am now using "MOVIEON=OFF" in stbof.ini so perhaps that was the key change I really needed

UPDATE: I tried switching to MOVIEON=ON and none of the solutions work anymore (compat/dxwnd/ts dlls). I changed that offhand a little while ago but that must have been the real fix. It seems that because the movie autoplays on startup that's actually what causes the crash as perhaps the format is no longer playable on new machines/new video drivers

Sorry for the spam XD

Re: Windows 10 problems/solutions please post them here

Posted: Tue Apr 26, 2016 2:40 pm
by thunderchero
alexgophermix wrote:For reference this is what my Compat tab looks like in dxwnd.
I just updated links to new version today for Dxwnd
viewtopic.php?f=23&t=3179

also on a side note, even though you turn off compatibility setting in properties, it is still set in windows registry :shock:
check
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

and it is possible when you changed to windows XP it removed run as admin in registry?

Edit; also it looks like DxWnd no longer needs to be set to run as admin :grin: developer must have fixed issue recently.
alexgophermix wrote:Sorry for the spam
this is not spam, other may have same problem

Edit 2;
alexgophermix wrote:I tried switching to MOVIEON=ON and none of the solutions work anymore (compat/dxwnd/ts dlls). I changed that offhand a little while ago but that must have been the real fix. It seems that because the movie autoplays on startup that's actually what causes the crash as perhaps the format is no longer playable on new machines/new video drivers
The movies use the iccvid.dll make sure it is still present in install folder.

Re: Windows 10 problems/solutions please post them here

Posted: Tue Apr 26, 2016 6:59 pm
by alexgophermix
check
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
This is the data:

Code: Select all

~^ DWM8And16BitMitigation
I would suggest maybe adding a step for setting MOVIEON=OFF in your original post as that seems to have been the golden ticket

Re: Windows 10 problems/solutions please post them here

Posted: Wed Apr 27, 2016 9:14 am
by thunderchero
sorry it took so long to post back, storm rolled though and to my power out until late last night. :mad:
alexgophermix wrote:I would suggest maybe adding a step for setting MOVIEON=OFF in your original post as that seems to have been the golden ticket
I plan on re-writing many of the first posts with more current up-to-date info.

back to video problem
Most systems will not crash game on video failure (it just skips video even with ini setting of MOVIEON=ON) That is why this is so strange :shock:

but if you don't mind test one more time?
BOTF uses "ICCVID.DLL" for video playback, the installer installs version 1.10.0.6

DxWnd has a redist folder with a newer version of "ICCVID.DLL" (version 1.10.0.11) Just copy and replace file in BOTF install path and re-test video playback in game. (this version works on my system also)

if that works great, but if it fails, you should have an even newer version in C:\Windows\SysWOW64 version 1.10.0.12 (this version skips video on my system)

good luck

Re: Windows 10 problems/solutions please post them here

Posted: Wed Apr 27, 2016 11:14 am
by alexgophermix
Ok here's what I've tried;

Current - no compat settings, not using dxwnd, not using TS dlls, MOVIEON=OFF, 1.10.0.6 - WORKS
Control - no compat settings, not using dxwnd, not using TS dlls, MOVIEON=ON, 1.10.0.6 - CRASH
test1 - no compat settings, using dxwnd, not using TS dlls, MOVIEON=ON, 1.10.0.6 - CRASH
test2 - no compat settings, not using dxwnd, not using TS dlls, MOVIEON=ON, 1.10.0.11 - CRASH
test3 - no compat settings, using dxwnd, not using TS dlls, MOVIEON=ON, 1.10.0.11 - CRASH
test4 - no compat settings, not using dxwnd, not using TS dlls, MOVIEON=ON, 1.10.0.12 - WORKS (doesn't play video though)
test5 - no compat settings, using dxwnd, not using TS dlls, MOVIEON=ON, 1.10.0.12 - WORKS (doesn't play video though)
if that works great, but if it fails, you should have an even newer version in C:\Windows\SysWOW64 version 1.10.0.12 (this version skips video on my system)
So far all test seem to point to disabling video on my system being the only solution. Thanks for the suggestion. I hope this data helps you out

Re: Windows 10 problems/solutions please post them here

Posted: Wed Apr 27, 2016 12:42 pm
by thunderchero
As I said before this is very strange, your system is first one I know of having this problem.

one other thing you stated makes me wonder it might be a sound problem (video and sound are separate files, but load at same time)
alexgophermix wrote:I noticed that all the sound was set to 0 when the game first successfully started so I changed that back.
if you did not change it in stbof.ini how did it change?

simple test here, try to open the "intro.wav" with any audio player.
thunderchero wrote:also did it install correctly,
Did you ever try to uninstall/reinstall game?

Re: Windows 10 problems/solutions please post them here

Posted: Wed Apr 27, 2016 1:00 pm
by alexgophermix
I used to have the game installed when I had Windows 7 but I uninstalled it before upgrading to Windows 10.

I tried playing the WAV file in Groove Music, Windows Media Player and VLC and in all 3 it only played the sound, there was no video component.

Re: Windows 10 problems/solutions please post them here

Posted: Wed Apr 27, 2016 1:25 pm
by thunderchero
This might be the cause of all the problems.
alexgophermix wrote:before upgrading to Windows 10
this is just a personal preference, I never use "upgrade" of windows installs. what I did was backed up everything then accept upgrade offer and allow it to upgrade, but same day wipe hard drive and did full install. The reason why too many carry over files ect from old OS version.

Re: Windows 10 problems/solutions please post them here

Posted: Mon Jun 20, 2016 7:19 pm
by mickar1
I don't understand the instructions to get botf working using windows 10. By working, I mean stop the mouse from lagging so much. Also, I'm the original mickar. Lost my password and I think I used a different email when setting up my account.

Re: Windows 10 problems/solutions please post them here

Posted: Mon Jun 20, 2016 8:21 pm
by thunderchero
Hi Mickar,

good to see you again.

best thing for mouse lag in windows 10 is DxWnd
viewtopic.php?f=23&t=3179
this is a simple start up/hooking program (open this program before starting a game) and actually make game run smoother.

playable in fullscreen and windowed

DxWnd is also part of the release candidate for new multi installer (final release 1-2 weeks)
viewtopic.php?f=23&t=3465

Re: Windows 10 problems/solutions please post them here

Posted: Tue Jun 21, 2016 2:02 pm
by mickar1
That's the part I don't understand. I download DxWnd, then extract the files, then what?

Re: Windows 10 problems/solutions please post them here

Posted: Tue Jun 21, 2016 2:11 pm
by thunderchero
mickar1 wrote:then what?
open the folder you extracted and find "dxwnd.exe" start this program. a small window will pop up and if game/mod is installed you will see a green light on left.

after that you can double click in DxWnd to start game or use normal shortcuts. just the DXwnd window needs to remain open while playing game.

Re: Windows 10 problems/solutions please post them here

Posted: Tue Jun 21, 2016 2:57 pm
by mickar1
Success!!! Just like the original.

Thanks. ;p

Now, I just need to change the number of starting systems in Ultimate Dominion mod to 2 systems instead of the 5 or 6. You once told me how.

Re: Windows 10 problems/solutions please post them here

Posted: Tue Jun 21, 2016 3:48 pm
by thunderchero
mickar1 wrote:Now, I just need to change the number of starting systems in Ultimate Dominion mod to 2 systems instead of the 5 or 6. You once told me how.
here is the start of discussion.
viewtopic.php?f=114&t=629#p41032