New Multi Installer (Full Game Install) available updated 7-2-16

This forum contains threads from support forum outdated or no longer neede.

Moderator: thunderchero

SeaBee-T
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 74
Joined: Fri May 23, 2008 2:00 am

Re: Multi Installer RC3 available (open testing)

Post by SeaBee-T » Fri Jun 03, 2016 11:17 am

Thought it did, but i did a fresh install of 1.0.3 and did the change again, didn't work. :(

User avatar
captaindusk
Commander
Commander
Posts: 293
Joined: Sat Feb 07, 2009 3:00 am

Re: Multi Installer RC3 available (open testing)

Post by captaindusk » Fri Jun 03, 2016 11:19 am

thx for the hint, should have noticed it myself
for me after changing the paths in ini the game tried to launch but then crashed to desktop with "trek.exe has stopped working" message.
Last edited by captaindusk on Fri Jun 03, 2016 11:32 am, edited 2 times in total.

SeaBee-T
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 74
Joined: Fri May 23, 2008 2:00 am

Re: Multi Installer RC3 available (open testing)

Post by SeaBee-T » Fri Jun 03, 2016 11:19 am

Ok, I copied 1.0.2 stbof.ini to overwrite the 1.0.3 stbof.ini and it works, something about the stbof.ini settings. Will investigate further.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6059
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Multi Installer RC3 available (open testing)

Post by thunderchero » Fri Jun 03, 2016 11:22 am

SeaBee-T wrote:Thought it did, but i did a fresh install of 1.0.3 and did the change again, didn't work. :(
but just test there is a problem with adjusting path of stbof.ini

so you may be right

User avatar
captaindusk
Commander
Commander
Posts: 293
Joined: Sat Feb 07, 2009 3:00 am

Re: Multi Installer RC3 available (open testing)

Post by captaindusk » Fri Jun 03, 2016 11:24 am

also copied the ini over from backup and it works for me too

SeaBee-T
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 74
Joined: Fri May 23, 2008 2:00 am

Re: Multi Installer RC3 available (open testing)

Post by SeaBee-T » Fri Jun 03, 2016 11:24 am

Ok, so I confirmed re-writing the stbof.ini works for me on a fresh install. I installed my 1.0.3 BOTF in the following folder D:\Games\BOTF\ so my stbof.ini reads the following:

CDPATH=D:\Games\BOTF\
HDPATH=D:\Games\BOTF\

It did not work in the earlier testing as this path is case-sensitive. I'm using DxWnd being run as an administrator.

What I noticed that is different between 1.0.2 installer and the 1.0.3 installer is that the 1.0.2 installer picks up the game installation directory from the registry. Maybe something to include in the installer package, like what was done on 1.0.2?

Edit: My bad, did a reinstall and noticed that it DOES pick up the custom game installation directory before extracting all the files. So I am not sure why stbof.ini does not register the custom directory.

Edit 2: Followed up with a completely fresh install of 1.0.3 again, corrected the stbof.ini, and am facing the crashing as reported by captaindusk.

Edit 3: Noticed that I was missing a "\" after \BOTF\, so that is what's causing the crashes. Now all is good.
Last edited by SeaBee-T on Fri Jun 03, 2016 11:39 am, edited 1 time in total.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6059
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Multi Installer RC3 available (open testing)

Post by thunderchero » Fri Jun 03, 2016 11:38 am

just went though all the installer files and it is not adjusting path of stbof.ini at all. :shock:

this happened when I add code to adjust path for DxWnd, could you both confirm this is adjusted correctly?

So I will need to add code back for adjusting install path for stbof.ini and compile new installer.

new file should be up later today.

thanks for all your help figuring this out guys

btw I should have noticed on SeaBee-T screenshot install path change

SeaBee-T
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 74
Joined: Fri May 23, 2008 2:00 am

Re: Multi Installer RC3 available (open testing)

Post by SeaBee-T » Fri Jun 03, 2016 11:40 am

DxWnd picks up the custom directory automatically, no problems there.

Anyway, thank you for keeping BOTF alive, TC and the rest of the AFC crew. :up:

User avatar
captaindusk
Commander
Commander
Posts: 293
Joined: Sat Feb 07, 2009 3:00 am

Re: Multi Installer RC3 available (open testing)

Post by captaindusk » Fri Jun 03, 2016 11:46 am

confirmed
Glad I could finally contribute something again after all my silent lurking around :grin:
thx for all the hard work :up:

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6059
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Multi Installer RC3 available (open testing)

Post by thunderchero » Fri Jun 03, 2016 11:55 am

well at least that worked correctly,

compiling now, but will take a little to upload that large of file. check back in an hour or so for new link.

User avatar
captaindusk
Commander
Commander
Posts: 293
Joined: Sat Feb 07, 2009 3:00 am

Re: Multi Installer RC3 available (open testing)

Post by captaindusk » Fri Jun 03, 2016 12:20 pm

I don't know if this is still relevant since new installer is already compiling but I just reinstalled RC3 added stbof.ini from 1.0.2. and edited the paths.

Game loads up fine with and without dxwnd but it doesn't generate a galaxy at all. i tried multiple times and also waited for race starting screen to fully complete.
BotF.jpg
BotF.jpg (147.46 KiB) Viewed 2815 times

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6059
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Multi Installer RC3 available (open testing)

Post by thunderchero » Fri Jun 03, 2016 12:49 pm

From your image it is using 800 x 600 gui files but 1024 x 768 trek.exe :shock:

but expect it is also related to path issue, possibly getting location from backup?.

before installing RC4 be sure to remove all backups you have created and uninstall current install.

just started uploading new file now, after testing using several different locations for both english and german.

User avatar
captaindusk
Commander
Commander
Posts: 293
Joined: Sat Feb 07, 2009 3:00 am

Re: Multi Installer RC3 available (open testing)

Post by captaindusk » Fri Jun 03, 2016 12:55 pm

Nevermind my last post it's working now. I deleted everything backups etc and just installed RC3 and edited the paths. now everything is working fine. looking forward to RC4. :smile:

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6059
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Multi Installer RC4 available (open testing) updated 6-3-16

Post by thunderchero » Fri Jun 03, 2016 1:53 pm

sorry to all that experienced problems with stbof.ini install path issue. it was a large over site on my part.

And a big thanks to all who help track down problem.

New link is up for RC4

file no longer available

you need to uninstall RC3 or multi main before installing RC4 (mods do not need to be uninstalled)

changes to RC4
fixed install path edit problem for different locations from default
added gui fixes that were missing in 1024 x 768

User avatar
EnPhreg
Lieutenant-Commander
Lieutenant-Commander
Posts: 130
Joined: Thu Jul 10, 2008 2:00 am

Re: Multi Installer RC4 available (open testing) updated 6-3-16

Post by EnPhreg » Mon Jun 13, 2016 1:37 pm

i've noticed that some of the cardassian ships now have newer textures (galor, hideki) and are not vanilla anymore.
was this only for cosmetic reasons?

Post Reply

Return to “Support Archive”

Who is online

Users browsing this forum: No registered users