New Multi Installer (Full Game Install) available updated 7-2-16

This forum contains threads from support forum outdated or no longer neede.

Moderator: thunderchero

User avatar
EnPhreg
Lieutenant-Commander
Lieutenant-Commander
Posts: 130
Joined: Thu Jul 10, 2008 2:00 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by EnPhreg » Sat Jul 23, 2016 10:04 am

tried your new installer today (7-2-16) and if i install the game with all enhancements, the game won't start. some .exe crash.
i managed to figure out what's the problem. the new gui fixes are the problem. if i don't install them, everything works fine.
and idea what's wrong with them?

Edit:
false alert. but very strange. first it seemed like i discribed above. because i've tested it through different installs. than i installed it again to keep the install, but wihout the gui enhancement, and suddenly this install also didn't worked anymore. but now, after several more installs and deinstalls. all installs work fine (also with gui enhancements). very strange. maybe the installer has some instability?? didn't noticed such a strange behavior at any multi installer before. or it's my comp? hm...

you ever noticed something like that thunder??

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by thunderchero » Sat Jul 23, 2016 11:01 am

EnPhreg wrote:you ever noticed something like that thunder??
no, this has never happened to me before, since I never re-install without uninstalling first. :wink:

User avatar
EnPhreg
Lieutenant-Commander
Lieutenant-Commander
Posts: 130
Joined: Thu Jul 10, 2008 2:00 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by EnPhreg » Sat Jul 23, 2016 11:23 am

no, i've uninstalled the game every time before installing the game again.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by thunderchero » Sat Jul 23, 2016 2:41 pm

EnPhreg wrote:no, i've uninstalled the game every time before installing the game again.
ok, just the way I read your post made me question.

also just to be clear multi installer should not be installed to 2 different locations at the same time. the second install would overwrite first registry settings.

next, then please double check the trek.exe properties in compatibility tab make sure all compatibility setting are unchecked if using DxWnd.

User avatar
EnPhreg
Lieutenant-Commander
Lieutenant-Commander
Posts: 130
Joined: Thu Jul 10, 2008 2:00 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by EnPhreg » Sat Jul 23, 2016 2:46 pm

i've made a game with the vanilla botf from main multi installer on a large map.
the large map was somewhat empty and i checked it in the trek.exe that there's only an average for space objects of 90 for large maps.
isn't that a little bit low? is 90 vanilla value?

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by thunderchero » Sat Jul 23, 2016 3:04 pm

EnPhreg wrote:is 90 vanilla value?
yes it is the vanilla value.

User avatar
EnPhreg
Lieutenant-Commander
Lieutenant-Commander
Posts: 130
Joined: Thu Jul 10, 2008 2:00 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by EnPhreg » Sun Jul 24, 2016 10:17 am

the problem with the not working install seems to have to do with the stbof.res.
if i install the game with same settings several times, it's randomly to me if the stbof.res is only around 65mb big or
98mb. if the stbof.res is 98mb big it's ok and all is working, but if the files only 65mb big, the game won't start.
don't no wants causing this error, but it seems that the install sometimtes 'lost' some files while extracting and packaging the stbof.res.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by thunderchero » Sun Jul 24, 2016 1:32 pm

EnPhreg wrote:don't no wants causing this error, but it seems that the install sometimtes 'lost' some files while extracting and packaging the stbof.res.
I don't know why you might be having this problem. while testing I installed close to 1000 times or more and never experienced this issue.
EnPhreg wrote:it's randomly to me if the stbof.res is only around 65mb big or
98mb. if the stbof.res is 98mb big it's ok and all is working, but if the files only 65mb big, the game won't start.
this sounds like the mod3.bat/mod3.kix (see below) not running properly or interrupted. the question is how or why.

but I will explain the steps the installer take while installing/editing files

done by inno installer

when the installer starts it gets user input for language to use during install
install path selected by user
options selected by user
files are extracted as needed, in order below
readme htm extracted to app path
Dxwnd folder extracted to app path
english.res and german.res extracted to app path
install/option files extracted to temp folder
all Registry entries are written
start menu and desktop shortcuts created
run temp files as needed by options selected

the files inno runs are bat/kix script files (command prompts, Important never to close any command prompt window)
here is the order the bat files run

note; all kix files use botf registry to get proper location of files to add/edit files

english.bat/english.kix; this will extract the english.res to app path for basic install of game. (if german, german.bat/german.kix)
DX.bat/Dx.kix; this will adjust the dxwnd.ini to proper app path for vanilla and mods (needs improvement for setting mods path)
mod.bat/mod.kix; this will add the hob fix patch to stbof.res
mod1.bat/mod1.kix; this will add the replacement ship gifs to stbof.res
mod2.bat/mod2.kix; this will add the replacement build screen images to stbof.res
mod3.bat/mod3.kix; this will add the gui fixes to stbof.res
BOTF2.BAT/BOTF2.kix; this will add 1024 gui files, alt.res, german gui files if german.snd is present and copy trek.exe to temp folder for editing.
botf1024.bat/bof1024.patch; this will edit the trek.exe in temp folder using a patching tool by QD
BOTF1.BAT/BOTF1.kix; this will move the edited trek.exe to app path from temp folder.
E3D1.BAT/E3D1.kix; this will edit the stbof.ini for proper install/cd path. (if german, G3D1.bat/G3D1.kix)

After all that the inno installer will create un-installer file and add to windows "add and remove programs"

if any of the above is interrupted/stopped by user will cause error.

just a side note, on final screen of installer when "finish" button is clickable you can use start button to go to your temp folder and view/copy the temp files from installer to different location for those who what to take a closer look at installer files.

after the "finish" button is clicked the temp files are deleted.

so the installer has a lot to get done in a short period of time. and the user can cause errors in install if he closes command window.

User avatar
barra85
Cadet 3rd Year
Cadet 3rd Year
Posts: 10
Joined: Sun Sep 04, 2016 8:42 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by barra85 » Sun Sep 04, 2016 8:51 am

Before i ask,
I would first like to thank everyone who has put in so much time and hard work keeping this game alive, this is my first attempt in over 15 years or so at trying to replay one of my all time favourite games.

Ok so i have tried to install the game a few times now but just want to know if the below screenshot is normal. I ask because if i press ignore on every file it comes up with (which is ALOT) feel like almost every file, then the install will still finish and the command boxes do finish running. The game will then run... bit buggy but none of the mods i install work properly and i also get the same below screenshot when installing them.
Attachments
2016-09-04 (1).png
2016-09-04 (1).png (366.3 KiB) Viewed 2724 times

User avatar
darthmaul
Cadet 4th Year
Cadet 4th Year
Posts: 15
Joined: Sat Jul 28, 2012 6:26 pm

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by darthmaul » Sun Sep 04, 2016 11:41 am

Installed the new Installer from this thread and afterwards the Ultimate Dominion Mod 3.0.1dbb. Running it with DxWnd as Adminstrator and after starting a game the loading screen appears for one second and then the game crashes everytime. Tried 2 different machines (both Windows 10), always the same. I tried installing only the core game and none of the patches - no difference. Running the original game works but UDM simply crashes. Never happened on the old installer. Any ideas?

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by thunderchero » Sun Sep 04, 2016 12:50 pm

barra85 wrote:Ok so i have tried to install the game a few times now but just want to know if the below screenshot is normal.
no it is not normal.

try to run installer as administrator if that does not help, re-download installer and try again.
darthmaul wrote:after starting a game the loading screen appears for one second and then the game crashes everytime.
loading first window or loading game after race selection? also any crash log in UDM folder.

User avatar
barra85
Cadet 3rd Year
Cadet 3rd Year
Posts: 10
Joined: Sun Sep 04, 2016 8:42 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by barra85 » Sun Sep 04, 2016 1:30 pm

thunderchero wrote:
barra85 wrote:Ok so i have tried to install the game a few times now but just want to know if the below screenshot is normal.
no it is not normal.

try to run installer as administrator if that does not help, re-download installer and try again.
darthmaul wrote:after starting a game the loading screen appears for one second and then the game crashes everytime.
loading first window or loading game after race selection? also any crash log in UDM folder.
Administrator made no difference but spent about 3 hours clicking retry on every file that popped up and it looks like the installation worked but have not tried any of the mods yet

User avatar
barra85
Cadet 3rd Year
Cadet 3rd Year
Posts: 10
Joined: Sun Sep 04, 2016 8:42 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by barra85 » Sun Sep 04, 2016 1:36 pm

ok hasn't gone quite to plane. now the screen size is all out of whack as below.

Please bear with me as this is all new to me. Haven't tried modding or playing with files since back to the old ST armada days
Attachments
2016-09-04 (2).png
2016-09-04 (2).png (326.16 KiB) Viewed 2704 times

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by thunderchero » Sun Sep 04, 2016 1:42 pm

barra85 wrote:ok hasn't gone quite to plane. now the screen size is all out of whack as below.
was this after running as admin? but it still looks like the installer is not fully running or interrupted.

note; never close any command prompt windows. while they are open they are preforming important install tasks.

User avatar
barra85
Cadet 3rd Year
Cadet 3rd Year
Posts: 10
Joined: Sun Sep 04, 2016 8:42 am

Re: New Multi Installer (Full Game Install) available updated 7-2-16

Post by barra85 » Sun Sep 04, 2016 1:58 pm

thunderchero wrote:
barra85 wrote:ok hasn't gone quite to plane. now the screen size is all out of whack as below.
was this after running as admin? but it still looks like the installer is not fully running or interrupted.

note; never close any command prompt windows. while they are open they are preforming important install tasks.
yes all this after running as admin, strange as previously when i just pressed ignore on all the errors during install the vanilla version played fine. I think it could be a corrupted download of the installer so i have deleted everything again and will attempt to re-download the installer from the first post on page.

See i never closed any of the command prompts that ran after the initial package installer had finished so it wasn't anything going wrong there. it seems to be something to do with temp files?

Post Reply

Return to “Support Archive”

Who is online

Users browsing this forum: No registered users