Galaxies Mod v0.2.4 - Feedback & Suggestions

Galaxies MOD; showcase and support/discussion/questions/suggestions/reviews

Moderator: thunderchero

Should the Borg utilize Colony Ships as a means by which to expand?

Yes
23
43%
No
31
57%
 
Total votes: 54

User avatar
ZeroChance
Lieutenant-Commander
Lieutenant-Commander
Posts: 144
Joined: Sat Apr 26, 2008 2:00 am
Location: Sudbury, ON

Post by ZeroChance » Sat Feb 06, 2010 10:34 pm

Here I am again with more news! I suffered from a CTD when attempting to go into the tactical combat screen... the battle was between my light warbirds (before upgrade) and Dom battle cruiser II, Attack ship III, Strike cruiser II, Heavy cruiser, Destroyer II, Dom controlled Son'a battlecruiser II, Tellarite cruiser, and Borg assimilator II. As soon as I pressed the "Fight" button I got the CTD. Crash log below:


-------------------------------------
ST:BOF Sat Feb 6 19:19:35 2010

Version Under Test: 72
File: ..\..\source\ui\tactical\objview.cpp, Line: 1648, 0
Initialize State: 31
Player Empire: 4 Starting Seed: 1265383597
Galaxy shape: 0 Galaxy Size: 0
Turn State: 20
Turn Number: 126

Edit: The crash occurs no matter what the combination of my ships I bring to the battle... unfortunately, that doesn't narrow down the cause all that much.

User avatar
Tethys
Past Administrator
Past Administrator
Posts: 2065
Joined: Fri Jul 18, 2008 2:00 am
Location: Your mom's bed ;)
Contact:

Post by Tethys » Sat Feb 06, 2010 11:17 pm

Thank you Zero, i will have to look into this crash. From the looks of it it seems to have something to do with the User Interface (though I did not edit anything in the UI) except for maybe the word 'Defense' (you will notice it missing it will show only a blank spot in the ship specs in combat)

I wish i could diagnose these bugs a bit better.. :(
Not for the weak of heart...
Image
GALM <--- GALM/Galaxies Mod

User avatar
Tethys
Past Administrator
Past Administrator
Posts: 2065
Joined: Fri Jul 18, 2008 2:00 am
Location: Your mom's bed ;)
Contact:

Post by Tethys » Sun Feb 07, 2010 4:01 pm

Zero might you by any chance have the save for this? I want to take a look at it
Not for the weak of heart...
Image
GALM <--- GALM/Galaxies Mod

User avatar
ZeroChance
Lieutenant-Commander
Lieutenant-Commander
Posts: 144
Joined: Sat Apr 26, 2008 2:00 am
Location: Sudbury, ON

Post by ZeroChance » Wed Feb 10, 2010 1:21 am

I'm getting a different kind of crash now in tactical combat... but no crash logs to speak of.

I'll enter the combat screen, issue orders and then I get a CTD. From what I remember, it's similar to the phaser firing issue that used to come up when it was first discovered how to give phasers to new ship models. Basically, the turn processes but before any firing can begin it CTD.

This could just be another vanilla bug, coming up with the increase in play... but I figured I'd mention it just to be safe.

EDIT: I also wanted to mention that the Borg AI doesn't seem to be building any of the cubes... I'm at turn 160ish in a game as Rom and the borg only build the sphere command ships for commands...

User avatar
mickar
UDMIII tournament winner
UDMIII tournament winner
Posts: 338
Joined: Wed Jun 18, 2008 2:00 am
Location: Surrey, BC Canada

Post by mickar » Wed Feb 10, 2010 5:59 pm

Tethys,

Any word on when you're gonna put out an updated version? I'd like to continue testing but want the changes we posted made first if possible.

User avatar
Tethys
Past Administrator
Past Administrator
Posts: 2065
Joined: Fri Jul 18, 2008 2:00 am
Location: Your mom's bed ;)
Contact:

Post by Tethys » Wed Feb 10, 2010 11:05 pm

Yeah Im getting around to that Mickar i just want to make sure I get any bug/fix changed so that you guys dont have to download multiple files all the time.

You will get a PM when Ive got an update for ya or ill pop on Wz
Not for the weak of heart...
Image
GALM <--- GALM/Galaxies Mod

User avatar
exceL
Cadet 4th Year
Cadet 4th Year
Posts: 16
Joined: Fri Jun 19, 2009 2:00 am

Post by exceL » Fri Feb 12, 2010 5:12 am

Great mod Tethys! Although I haven't played as Federation yet, I'm eager to see what that Starbase with 1000 phaser beams is capable of 8O Also eager to encounter the super battleship from the Doms...unfortunately neither has happened :(

Anyhow...quick comment: there are a LOT of energy structures, more so than the screen can fit. Just tried out starting as Federations and bought an energy structure real quick - it seems as though it "bumps" another energy structure out of the window. Aside from this, there is nothing more I can add that someone has not already mentioned yet. Hope this is helpful!

User avatar
exceL
Cadet 4th Year
Cadet 4th Year
Posts: 16
Joined: Fri Jun 19, 2009 2:00 am

Post by exceL » Sat Feb 13, 2010 1:35 am

Hmm quick question for the other beta testers...

After playing two games up to turn 100 on t5 one time as the Borg and the other as Klingon, I didn't meet much resistance from one or two major empires for the entire 100 turns. In addition to this, there was little to no diplomacy amongst the AI - not to mention a few of them kept sending non-aggression treaties to me. I saved the game and re-opened it up with the -Mudd extension and in both games, there was at least one major empire who did not do a thing. The AI barely expanded, constructed any ships, or commit to any diplomacy. All they did in those 100 turns was research. After this, I started another new game as Federation and on turn 40...three of the other major empires have only their starting ships (if they had survived) and nothing more. Has this been a common occurrence for you guys too?

This has happened once or twice to me playing UDM but certainly not 3 times in a row =/ Gonna try to start up another game again and hope for more luck.

User avatar
ZeroChance
Lieutenant-Commander
Lieutenant-Commander
Posts: 144
Joined: Sat Apr 26, 2008 2:00 am
Location: Sudbury, ON

Post by ZeroChance » Sat Feb 13, 2010 12:35 pm

@exceL

Yea, I was about to write a report on the same thing. Currently playing a T3 game as Dom and the only empire with more than 5 systems is Rom at 10. But I've got around 30, so definitely not a fair game. Most of the AI powers seem to be cool with just sitting around not building ships.

I'm starting to wonder that maybe the high speed at which research is completed is flooding the build list with upgrades...

User avatar
exceL
Cadet 4th Year
Cadet 4th Year
Posts: 16
Joined: Fri Jun 19, 2009 2:00 am

Post by exceL » Sat Feb 13, 2010 1:51 pm

That could quite possibly be the reason in your game, but I played t5 in all my games so upgrades shouldn't be a factor in my case. Strangely enough, and likewise with you, the only empire that seemed to be building normally (as far as I could tell) was the Romulans. :?

User avatar
Tethys
Past Administrator
Past Administrator
Posts: 2065
Joined: Fri Jul 18, 2008 2:00 am
Location: Your mom's bed ;)
Contact:

Post by Tethys » Sat Feb 13, 2010 7:20 pm

I will be looking into these as Ive just added them to the bugs list, so I will let you all know when I have an uptade version for u. Also please keep with the feedback it does help alot for a good and thoroughly researched mod :D
Not for the weak of heart...
Image
GALM <--- GALM/Galaxies Mod

User avatar
mickar
UDMIII tournament winner
UDMIII tournament winner
Posts: 338
Joined: Wed Jun 18, 2008 2:00 am
Location: Surrey, BC Canada

Post by mickar » Sat Feb 13, 2010 7:35 pm

I've stopped testing due to too fast shipbuilding and too fast research. Kinda takes the fun out of it. Nothing personal.

User avatar
ZeroChance
Lieutenant-Commander
Lieutenant-Commander
Posts: 144
Joined: Sat Apr 26, 2008 2:00 am
Location: Sudbury, ON

Post by ZeroChance » Sat Feb 13, 2010 8:02 pm

So it seems as though the lower techs aren't having much trouble with expansion and ship building... in a T1, large map, game right now as Borg and the other empires have decent sized fleets and empires by turn 60.

Maybe it has something to do with the large map? When I played the smaller maps the empires were quick to expand and build up fleets....

User avatar
exceL
Cadet 4th Year
Cadet 4th Year
Posts: 16
Joined: Fri Jun 19, 2009 2:00 am

Post by exceL » Sat Feb 13, 2010 10:37 pm

@ Zero,

Hmm, it seems the problem may be more wide-spread..all my games were small irregular t5 impossible maps, and the AI still encountered a "stalling" problem I guess we could call it. After running a few trials out of curiousity with the -Mudd extension and just clicking turn up until turn 50-100, it seems that the Romulans are consistently having no problems building, while the Borg and Klingons have problems. In a more 50/50 outcome, the Doms either started building after a certain amount of turns (around turn 30 for one game and around turn 60 for another) or did not build at all like the other empires. Everything in this post prior to this line occurred while using Federation.

Using Borg, however, I encountered (I believe) one major empire having trouble expanding while the the rest were doing fine. Strange issue we have at hand here...

User avatar
exceL
Cadet 4th Year
Cadet 4th Year
Posts: 16
Joined: Fri Jun 19, 2009 2:00 am

Post by exceL » Tue Feb 16, 2010 5:02 am

Couple more reports...please let me know if my reports are even helpful at all lol :)

After doing a bit of tinkering with UE (mostly adding on starting buildings for every race EXCEPT Romulans as it seems they have the least trouble building up ships), my game right now at turn 50 is going somewhat well. All major empires seem to be building ships, although it seems the computer is still a bit slow. Strangely enough, the Romulans have become the slowest builders whilst the Borg, Klingons, and Dominion have built up semi-decent fleets. A few things to point out (just noticeable differences in the AI play-style): 1) The AI Dominion is expanding (colony-wise) unusually fast. Never in UDM or normal BOTF have I seen the AI colonize so much. To clarify, I'm not saying this is a bad thing - I like the AI expanding their territory, however, their fleet is still lacking. 2) With the -Mudd extension on and just pushing turn a few times for curiosity, the AI seems quite adamant still in building structures...lots and lots of structures. In UDM, most of the starting systems would be producing ships. So far that I've seen in this mod, the AI seems to only build ships on their respective home-worlds, while their remaining starting systems continually build structure after structure. Again, I haven't played past turn 100 because every time I've used the -Mudd extension to see whether the AI is still building or not, the AI's fleet is quite inferior to mine...and playing out the game would be boring. 3) There seems to be a lack of diplomacy amongst the AI. The interaction between AI major empires and minor races seems normal, but as far as I've seen, there does not seem to be many treaties signed nor war declared. Although once, two major empires declared war on me simultaneously. This event usually leads to the two empires strengthening their relationship. However, 10 turns later, those two empires were still neutral with each other. 4) Before putting this out, I remind you again that I have tinkered with starting structures in that all major races have more of each starting structure, in hopes the AI will produce ships. With this in mind, by turn ~30-40 with Loyal morale, almost every ship only requires one turn to be produced, besides the Battleship and the cloaking Defiant I believe. I don't really care about this tbh - I'm just pointing it out.

That is about it off of the top of my head. I hope this information is relevant and useful for future modding :) Hoping in the near future to build up a canon Federation task force thinking that it is powerful to suddenly see the Dominion declare war and surprise me with 3x the size of my fleet like in UDM...

Post Reply

Return to “Galaxies MOD”

Who is online

Users browsing this forum: No registered users