Crash logs and solutions

General Modding Information/Questions; support/discussion/questions

Moderator: thunderchero

Forum rules
:idea: Please search before starting new topic. :idea:
There is a good chance it has already been asked.
User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6068
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Crash logs and solutions

Post by thunderchero » Sun Apr 14, 2013 9:29 am

Lukas2409,

you can still use UE to edit saved game, if you read my post I said in "most cases"

Editing saved games is mainly for testing btw. Dcer has removed option a couple times in the past for problems like this but modders need it to test code changes.

but you should keep in mind that most of the testing of saved games was done on turn 1. So as game progresses you should not edit most things.

but moving systems and adding starbases is never suggested.

but always backup your save before editing. The main problem is still though you may not get an error for many turns.

thunderchero

User avatar
Lukas2409
Ensign
Ensign
Posts: 23
Joined: Thu Mar 21, 2013 6:53 pm

Re: Crash logs and solutions

Post by Lukas2409 » Sun Apr 14, 2013 11:34 am

That's what happened to me, used it, did stuff, didn't get crash problems for over 30 turns :/ ah well

User avatar
Lukas2409
Ensign
Ensign
Posts: 23
Joined: Thu Mar 21, 2013 6:53 pm

Re: Crash logs and solutions

Post by Lukas2409 » Mon Apr 15, 2013 8:54 am

Strange I decided to break a treaty as part of the action in my turn and it's working again for some reason lol!

User avatar
enigma
Cadet 4th Year
Cadet 4th Year
Posts: 17
Joined: Thu May 08, 2008 2:00 am

Re: Crash logs and solutions

Post by enigma » Wed Dec 31, 2014 8:23 am

Here is an error I've never seen before and I also dont know how I created it:

Version Under Test: 72
File: scrllbar.c, Line: 288, minValue < maxValue
Initialize State: 31
Player Empire: 0 Starting Seed: 1420028004
Galaxy shape: 0 Galaxy Size: 1

All I know is, that the Cardassians are starting now without any ships and if you hit the "build ship" button, the game crashes. I checked stbotf.res but I couldnt find any error there.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6068
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Crash logs and solutions

Post by thunderchero » Wed Dec 31, 2014 8:30 am

enigma wrote:File: scrllbar.c, Line: 288, minValue < maxValue
this looks like some kind of GUI error.

thunderchero

User avatar
enigma
Cadet 4th Year
Cadet 4th Year
Posts: 17
Joined: Thu May 08, 2008 2:00 am

Re: Crash logs and solutions

Post by enigma » Fri Jan 02, 2015 7:21 am

Yep, I thought the same, but the question is where to find and how to correct it.

This error did not appear before I made some changes lately. I changes some things in the ship list and in the GUI ... but only for the Dominion, not for any other race.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6068
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Crash logs and solutions

Post by thunderchero » Fri Jan 02, 2015 10:05 am

enigma wrote:but the question is where to find and how to correct it.
That is the hard part on user created errors.

to correct what I would suggest is to use UE to extract any edited files. Use Edit/other/list of modified files. use "extract all"

next uninstall/reinstall mod and slowly add back in the edited files to see what file is in error (this may need to be done 1 file at a time)

thunderchero

User avatar
Xan_of_Borg
Ensign
Ensign
Posts: 20
Joined: Thu Oct 28, 2010 2:00 am

Re: Crash logs and solutions

Post by Xan_of_Borg » Mon Sep 21, 2015 7:20 pm

Hello! My game crashes since a few days!
Here my crash log:
ST:BOF Tue Sep 22 00:52:22 2015

Version Under Test: 72
File: ..\..\source\lexicon\lexicon.c, Line: 338, Invalid race Id encountered

Initialize State: 31
Player Empire: 1 Starting Seed: 1442875875
Galaxy shape: 0 Galaxy Size: 2
What can i do?
Hope you can help me!
Thanks

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6068
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Crash logs and solutions

Post by thunderchero » Mon Sep 21, 2015 7:37 pm

Xan_of_Borg wrote:Invalid race Id encountered
sounds like a race has been eliminated either by you or AI, But saved game is still recognizing the race.

if you have an older saved game before error you might be able to use that saved game. but current save is corrupt.

thunderchero

User avatar
Xan_of_Borg
Ensign
Ensign
Posts: 20
Joined: Thu Oct 28, 2010 2:00 am

Re: Crash logs and solutions

Post by Xan_of_Borg » Tue Sep 22, 2015 3:46 pm

Thats crazy, games i started new are crashing, old saved games are working without problems.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6068
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Crash logs and solutions

Post by thunderchero » Tue Sep 22, 2015 4:01 pm

Xan_of_Borg wrote:Thats crazy, games i started new are crashing, old saved games are working without problems.
have you edited anything? is this vanilla or a mod?

thunderchero

User avatar
Zweistein000
Ensign
Ensign
Posts: 21
Joined: Mon Apr 19, 2010 2:00 am

Re: Crash logs and solutions

Post by Zweistein000 » Tue Apr 18, 2017 6:39 pm

So here's one that has appeared before, but this tine i cant seem to fix it:

Code: Select all

-------------------------------------
ST:BOF Tue Apr 18 17:58:26 2017

Version Under Test: 72
File: guifile.c, Line: 131, i_t1_b.tga
Initialize State: 31
Player Empire: 1	Starting Seed: 1492531096
Galaxy shape: 2	Galaxy Size: 0
It's A CTD when you hover over a ship in the shipbuilding tab, caused by a corrupt .tga file.
Happens for EVERY model I try to import. Doesn't matter if they have been exported and re-imported or if I'm using a ship pack from the downloads page. Could this be because of the 1366 resolution?

EDIT: Finally found the [ code ] button

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6068
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Crash logs and solutions

Post by thunderchero » Tue Apr 18, 2017 7:10 pm

Are you using All in one installer for 1366 x 768?

when adding ships to 1366 x 768 you will need to create a new ship image (enlarged image) and rename it to i_***270.tga (*** must match prefix for ship you added)

new tga image size should be 270 x 225

but don't understand why you are getting error on "i_t1_b.tga" file. it should have been "i_t1270.tga"

EDIT
Note; UM5? if so it would be correct to use "i_t1_b.tga" for 1366 x 768, it has special code since 1024 used it already.

Also you might want to read this new topic
viewtopic.php?f=4&t=3557

User avatar
Zweistein000
Ensign
Ensign
Posts: 21
Joined: Mon Apr 19, 2010 2:00 am

Re: Crash logs and solutions

Post by Zweistein000 » Wed Apr 19, 2017 8:11 am

thunderchero wrote:
Tue Apr 18, 2017 7:10 pm
EDIT
Note; UM5? if so it would be correct to use "i_t1_b.tga" for 1366 x 768, it has special code since 1024 used it already.

Also you might want to read this new topic
viewtopic.php?f=4&t=3557
I've been made!
Yea I'm poking about UM5. Nothing for the public, though, just personal use (wouldn't really be fair otherwise). TY for the reply. I was looking for a topic like that before I posted, but I must have missed it.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6068
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Crash logs and solutions

Post by thunderchero » Wed Apr 19, 2017 8:45 am

Zweistein000 wrote:
Wed Apr 19, 2017 8:11 am
I was looking for a topic like that before I posted, but I must have missed it.
I created that topic after you posted issue :cool:

Post Reply

Return to “General Modding Information/Questions”

Who is online

Users browsing this forum: No registered users