The strange i_cl1270.tga image file crash

General Modding Information/Questions; support/discussion/questions

Moderator: thunderchero

Forum rules
:idea: Please search before starting new topic. :idea:
There is a good chance it has already been asked.
Post Reply
User avatar
Mr Sol
Ensign
Ensign
Posts: 46
Joined: Mon Apr 11, 2016 5:44 pm

The strange i_cl1270.tga image file crash

Post by Mr Sol » Wed Jun 20, 2018 4:04 pm

Thunder, could you throw some light into this?

I changed some of the ship models for all races and when Im close to finishing the ship selection process for my mod I stumbled with something unexpected:

When I go to the shipbuilding screen and pass the mouse over the list, while the images change I still got to see the same old pictures while Im using completely different models.

I went to the file list, extracted all the tga files since its in that list that the ship icons are located and after a somewhat boring manual search I isolated the file list where the ships's icon begin and end. After checking it a bit I localized the file being i_cl1270.tga. After that I begun to check the whole list and found out that the i_xxx270.tga files of all ships didnt change after i changed theyr respective models.

I thought with myself: Lets check the .zip file where the shippacks are to see whats in there and, with shock, I discovered that there is NO i_xxx270.tga version of the icon images for ship building in the udm3 shippack, so I wont bother looking the others, because I suppose they dont have it too.

Then I went to examinate the i_cl1270.tga file with irfanview, my favorite image viwer, and I found out its a 270x225x24bpp image. Ooooook, Mr Sol thought: I will smartly open the i_cl1170.tga file, resize it from 170x142x24bpp to 270x225x24bpp, save it as i_cl1270.tga selecting, of course, the save option to be a tga file, and import it with UE and I will have fixed the problem! Such ingenuity for these vulkan ears! :grin:

And then, I stood with horror :shock: when I saw that, when I go over the ship name at the shipbuilding list of the cardassians, that the game CRASH with impunity, leaving me behind just wondering WHY???

This makes no sense. This game is making fun out of me... :???:

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6072
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: The strange i_cl1270.tga image file crash

Post by thunderchero » Wed Jun 20, 2018 4:55 pm

First question what GUI 800 or 1024 or 1366 or 1920? each require different image sizes. (UE ship packs only have files for 800 x 600)

check this post
viewtopic.php?f=4&t=3557#p47791

User avatar
Mr Sol
Ensign
Ensign
Posts: 46
Joined: Mon Apr 11, 2016 5:44 pm

Re: The strange i_cl1270.tga image file crash

Post by Mr Sol » Wed Jun 20, 2018 5:01 pm

I ***think*** its 1366.

But I was using the right size without knowing it was right... 0.o

EDIT: Oook, I just found out what happened!

When I edited the image using irfanview it told me it was a 270x225x24bpp, inducing me into error, making me believe it was a 24bit bitmap, so I saved it as a tga 24bit. Then I had the idea of checking it with UE at the file list. When I clicked the i_cl1170.tga file UE showed the preview image but when I clicked the i_cl1270.tga it complained that the color depth was wrong: it should be 16bit, not 24bit.

I did the demanded changes and tested and voilá: it works! :D

Thanks for the help, thunder. That post gave me the idea of checking at the right place!

Post Reply

Return to “General Modding Information/Questions”

Who is online

Users browsing this forum: No registered users