Race Intro

Race Intros (videos); support/discussion/questions

Moderator: thunderchero

User avatar
Joker
Ensign
Ensign
Posts: 22
Joined: Thu May 01, 2008 2:00 am
Location: Vienna
Contact:

Race Intro

Post by Joker » Sat Feb 21, 2009 2:57 pm

Long time ....

my last secret

Race Intro's H.avi F.avi ....
muxing the avi and wav with adobe premiere 6
Tech demo R.avi

1) render you movie inside 3dmax or whatever 25fps (lossless compression)
2) cut the video using virtual dub max. 800x460 (lossless compression)
3) open premiere 6 add video and audio 22,5/16bit/stereo
4) adopt all setting
5) render

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Post by Flocke » Sat Feb 21, 2009 6:36 pm

nice, I knew it must work :)
btw, cooler Screen, is' ja komplett in Deutsch, hehe ;D

p.s. great to see you're still dedicated to BotF somehow ;)
If you only had time, right? ^^

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6066
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Post by thunderchero » Sun Feb 22, 2009 12:57 pm

Joker,

Romulan demo looks great, :wink:

But tried all day yesterday with no luck for new f.avi working in game.

I am not sure what I am doing wrong.

saved avi huffyuv v2.1.1 no audio with vitrualdub

saved wav file as 22,050 16bit stereo

added both to adobe 6.0 and set everything same way as yours image
file plays fine in windows media but is skipped in game.

I also tryed having video and audio joined first with same results.

I think I am not saving correctly I am saving with export timeline/movie

thunderchero

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6066
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Post by thunderchero » Fri Apr 03, 2009 1:04 am

Hi anyone,

Please help me I tried off and on til my trial has expired of adobe premiere 6,
with no working results. I have single frame images, avi, and wav sound.

If someone could get UDMIII dominion intro to work for next update it would be great.

PM me if you have made this work and would like to help.

thunderchero

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Post by Flocke » Fri Apr 03, 2009 7:10 am

Just had a look at it.
Tried adding a subtitle to the ferengi intro for testing and failed as well, but I think I know the reason, or at least one reason why it doesn't work for me. :lol:
I've been using virtualdub + VSFilter & Aegisub, btw., a cool freeware program to create subtitles. ( see http://www.youtube.com/watch?v=v0NojT5M8iQ - note, an installer is available by now ;) )

For saving as new video I had to select the video compression and selected the Cinepak Codec of course. But it uses the iccvid.dll from C:\Windows\System32 for compression that isn't working with botf anyway.
Easy way should be replacing it with the one you included for botf.
It might be the same for adobe premiere.
Although having same name, there seems to be an incompatibility issue with these two versions.

My current problem is, damn vista forbids me to replace that file, although being administrator! rofl
Shit damn vista, I'll first have to fight a little with vista before testing this. xD

Edit: Didn't found a way to get access in vista, but managed to replace the file by using my ubuntu linux live disc :lol:
But, although filesize is getting different now, meaning compression is different, it still doesn't work. Maybe Joker can have a look which version of the codec he's been using for compression.
I'll test a little bit more, maybe I can find something else...

Edit2: Ok, same audio issue, without of audio it works fine, even direct stream copy doesn't work with virtualdub, strange. I don't have adobe premiere to test, sry.

Edit3: I might have found another reason. Examining the video files with GSpot I found that the video files of botf use "AVI v1.0" while virtualdub creates them as "OpenDML (AVI v2.0)".
I couldn't find a way yet how to create files of avi 1.0 format.
But it would explain why botf is having troubles even though video AND audio keeps unchanged.
And if Joker is having an older or somehow different version of adobe premiere, that still uses AVI 1.0 format as container for the audio and video data, or it's configured different to use it, it would answer why we're having these troubles, thunderchero :)
For now I've enough of this..

Edit4: One last edit, R.avi from Joker is using "AVI v1.0, "rec list" style" as container format! You should check your's, thunder! go http://www.headbands.com/gspot/ :)

User avatar
Joker
Ensign
Ensign
Posts: 22
Joined: Thu May 01, 2008 2:00 am
Location: Vienna
Contact:

Post by Joker » Fri Apr 03, 2009 11:03 am

I've done everything under w2k

Cinepak(C) Codec 1.10.0.6
same as inside Botf-102-W2K-XP-9x-English-German.exe

The problem in my case was never the video itself
the audio was the problem
I can render a video without sound using Vdub
and view the video inside botf

You need to add the sound file in this special way as Adobe does
if you are able to render it using the old codec
(try too use a VM)

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Post by Flocke » Fri Apr 03, 2009 11:12 am

As I've edited earlier, adding sound is the problem for me as well now, but I don't have adobe premiere and thunder told he tried exact same settings with adobe premiere as you did with same result, sound still not working.

Strange thing is, using direct stream copy in virtualdub, for both, audio and video, so both keep absolutely unchanged, having right format, including all settings you told, still doesn't work if using sound.
The only difference I found so far is virtualdub automaticly using AVI v2.0 instead of 1.0, so I'm confident in this being the reason.

Your R.avi uses AVI 1.0 as well, dunno what's about the files thunder created, should be 2.0 if I'm right.
Maybe there's a setting in adobe premiere you forgot about, so it's using AVI 1.0, in virtualdub I didn't found one so far.

greets :)

p.s. although most people think of avi being for video, it's just a container format like .ogg, but including information about contained data. So if it's a different avi format, it might cause such interpretaion faults when sound is included but not with video only. Such behavior could be called "partially backward compatible" :lol:

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6066
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Post by thunderchero » Fri Apr 03, 2009 11:47 am

flocke could you translate german above in joker images?

I used babel fish to translate wonder if some thing is wrong there?

thunderchero

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Post by Flocke » Fri Apr 03, 2009 12:38 pm

Video:
============================
projectconfiguration:
videofilter:
------------------------------
Cinepak Codec of Radius
800x460 pixel (4:3)
25 fps
quality 100%
datarate: limit to 1000KB/sec, recompress always

Audio:
============================
22050Hz
16bit stereo
uncompressed
blocksize: 1frame
(computationoptions: expand rate conversion: very good
create audio preview files, if 5 or more active audio traces exist, 1 or more audiofilter are used) <-- should be irrelevant in my opinion

projectconfiguration:
keyframe and rendering:
------------------------------
half-images: top half-image first
keyframes all 150 frames



enough? =)
And please check your video files, if they use avi 1.0 or 2.0

Edit: just found the option "save old format avi..." in virtualdub, producing avi 1.0 files, still sound not working, but still wouldn't hurt to check your files, thunder.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6066
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Post by thunderchero » Fri Apr 03, 2009 8:40 pm

thanks thanks thanks thanks thanks thanks thanks thanks, :wink:

JUNK JUNK JUNK JUNK JUNK JUNK JUNK JUNK JUNK JUNK JUNK JUNK 8O

JUNQ to JUNK and it works :D

I sent flocke a copy of dominion intro and he compared them and JUNK

so once again flocke has done it.

thunderchero

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Post by Flocke » Sat Apr 04, 2009 6:08 am

Good that it's working now, hasn't been easy to find. :lol:

In Botf it seems to be hardcoded how to interpret the avi container.
Joker already told that it's similar to the way adobe premiere is storing avi1.0 files.
In VirtualDub, I found an option "Create sparse AVI..." in the Tool menu and an option "Expand sparse AVI...". These options are very useful for examining avi files on compatibility issues. Well, I didn't understand anything of the generated code, but it has been obvious that avi files written by virtualdub look quite different, although this doesn't seem to harm video-only avi playback in botf.
In contrast, the R.avi from Joker as well as the video file thunder sent me, look much more equal to the ones of botf, when viewing the sparse info.

Finally, with an hexeditor, I found that Thundercheros video is having a key named "JUNQ" while the one of Joker as well as the ones from BotF are using "JUNK". I changed, tested and it worked.

Having surfed the web a little, these are FourCC / Four Character Key-Codes, used as Tag-IDs by the RIFF / Resource Interchange File Format chunk format of avi files.

Having searched a little more, I found some notes in forums and documents like the following one:
NOTE: In the Adobe AVI and WAV handlers, for historical reasons, unused chunks get an ID of "JUNQ", not the standard RIFF "JUNK".

So in conclusion, BotF is using a very special, limited interpretation on avi 1.0 headers. It's different to the ones created by virtualdub, maybe fixable if someone wants to analyse or write an export plugin, and it's quite similar to the one of adobe premiere but not completely, at least not for the version Thunder is using. Luckily, fixing JUNQ by JUNK with an hexeditor is easy! :lol:

I dunno, why it's working right for Joker, maybe there's an hidden option within adobe for strictly using RIFF standard for preventing the JUNQ tags.

When I got it working, I couldn't believe, such a dumb problem, unknown tags should always be disgarded instead of just stopping video playback when detecting disgardable JUNK that's named JUNQ. Dumb BotF! Sry. :P

Anyway, I'm looking forward in getting some new race intros by now! 8)

cheers

User avatar
Joker
Ensign
Ensign
Posts: 22
Joined: Thu May 01, 2008 2:00 am
Location: Vienna
Contact:

Post by Joker » Sun Apr 05, 2009 2:18 am

Its definitely a OS problem (or filter problem)
If i render a movie using vdub i got JUNK inside the header and not JUNQ

Set up w2k indise a VirtualMachine
and trace it back piece by piece
But don't forget to add
Audio blocks: 1 Frame

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2546
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Post by Flocke » Sun Apr 05, 2009 2:37 am

Joker wrote:Its definitely a OS problem (or filter problem)
If i render a movie using vdub i got JUNK inside the header and not JUNQ
Neither is it an OS problem, nor a filter problem! It absolutely doesn't have to do with codecs! It's the avi container that get's written wrong, or let's say not BotF compatible!
video and sound are fine

And as I told, JUNQ is an Adobe specific issue, doesn't occure with vdub or any other program!

Again the quote: "NOTE: In the Adobe AVI and WAV handlers, for historical reasons, unused chunks get an ID of "JUNQ", not the standard RIFF "JUNK"."
You can find this in the following official document of adobe: http://www.adobe.com/devnet/xmp/pdfs/XM ... nPart3.pdf

It's just adobe premiere using JUNQ instead of JUNK in Thundercheros case. Thx anyway. :)

User avatar
zorkedup
Ensign
Ensign
Posts: 35
Joined: Tue Mar 10, 2009 2:00 am

Post by zorkedup » Mon Apr 06, 2009 12:15 am

I like the demo of the warbird,it's cool as ice,,,good work. I look forward to seeing this kind of break through in a future mod maybe. Once again nice job. :D :D :D :D

User avatar
severenth
Lieutenant-Commander
Lieutenant-Commander
Posts: 116
Joined: Sun Jun 08, 2008 2:00 am
Location: Oxford, United Kingdom

Post by severenth » Sun Apr 26, 2009 1:12 pm

im yet to try a 100% finshed n tested version, but at 25fps lossless could also be translated to

Adobe Premier Pro @ DV Pal compressor?

anyone care to comment before I commit fully into testing this method?

( for the intro screen )

besides, i though video and audio were seperate files ?
Last Multiplayer Game :-
update pending

Post Reply

Return to “Race Intros (videos)”

Who is online

Users browsing this forum: No registered users