BOTF Lag

General Modding Information/Questions; support/discussion/questions

Moderator: thunderchero

Forum rules
:idea: Please search before starting new topic. :idea:
There is a good chance it has already been asked.
Post Reply
User avatar
JeanNYGUARD
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 52
Joined: Fri Dec 12, 2008 3:00 am

BOTF Lag

Post by JeanNYGUARD » Fri Jan 11, 2013 2:34 am

Hey guys Im trying to start a game (Large Galaxy) UDM 3.0.1d. When I launch it everythings ok until i select a ship then my mouse cursor LAGS alot. I browsed the forums and saw a tip to remove system names, which I did, but I still have that issue. The mouse cursor moves perfectly smooth moving through the map and other screens, but the moment I select a ship it starts lagging. Sometimes I can launch the game and select a ship and for a few minutes it moves fine... but then by the 5 / 6 ship the lag comes back.

User avatar
jonesie85two
Lieutenant-Commander
Lieutenant-Commander
Posts: 201
Joined: Sat Apr 26, 2008 2:00 am

Re: BOTF Lag

Post by jonesie85two » Fri Jan 11, 2013 4:31 am

to be honest with you, this is an issue that has plagued this game since it was released. I very much doubt that there is a fix for it.

Sorry.

User avatar
Lathon
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 98
Joined: Thu Oct 15, 2009 2:00 am

Re: BOTF Lag

Post by Lathon » Fri Jan 11, 2013 12:12 pm

JeanNYGUARD wrote:Hey guys Im trying to start a game (Large Galaxy) UDM 3.0.1d. When I launch it everythings ok until i select a ship then my mouse cursor LAGS alot. I browsed the forums and saw a tip to remove system names, which I did, but I still have that issue. The mouse cursor moves perfectly smooth moving through the map and other screens, but the moment I select a ship it starts lagging. Sometimes I can launch the game and select a ship and for a few minutes it moves fine... but then by the 5 / 6 ship the lag comes back.
Do you have the graphic setting on SOFTWARE? that might be your problem....I remember this happened to me with UDM, but than i switched to SOFTWARE and it was fine...

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6401
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: BOTF Lag

Post by thunderchero » Fri Jan 11, 2013 12:29 pm

also windows 8 does not support BOTF.

thunderchero

User avatar
QuasarDonkey
Code Analyst
Code Analyst
Posts: 433
Joined: Tue Jul 26, 2011 8:29 pm
Location: Ireland

Re: BOTF Lag

Post by QuasarDonkey » Fri Jan 11, 2013 2:17 pm

Hi Jean. I've made a little patch that MIGHT help here. I can't test if it works, because BotF never lags for me :grin:

If you know how to hexedit, open GEN.MPR in a hex editor.

Code: Select all

0EB5: 01 -> 20
i.e. at file offset EB5, change 01 to 20 (hex). (You could also try setting it to 0 if 20 doesn't work.)

Let me know if this has any effect.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6401
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: BOTF Lag

Post by thunderchero » Fri Jan 11, 2013 2:30 pm

QuasarDonkey wrote:Let me know if this has any effect.
it had no effect on windows 8 mouse lag.

thunderchero

User avatar
QuasarDonkey
Code Analyst
Code Analyst
Posts: 433
Joined: Tue Jul 26, 2011 8:29 pm
Location: Ireland

Re: BOTF Lag

Post by QuasarDonkey » Fri Jan 11, 2013 2:34 pm

Thanks for testing. Would you mind also testing GEN.MPR with

Code: Select all

0EB5: 01 -> 08
and

Code: Select all

0EB5: 01 -> 00
What we're doing here is tweaking some rendering parameters (used for surface flipping). 08 disables VSYNC for example. I'm just guessing that this is related to the lag. I know it's a bit of a long shot...

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6401
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: BOTF Lag

Post by thunderchero » Fri Jan 11, 2013 3:55 pm

sorry no change (tried both), this is a strange bug even the planet rotation is jumpy.

thunderchero

User avatar
QuasarDonkey
Code Analyst
Code Analyst
Posts: 433
Joined: Tue Jul 26, 2011 8:29 pm
Location: Ireland

Re: BOTF Lag

Post by QuasarDonkey » Fri Jan 11, 2013 4:13 pm

The Windows 8 issue might be unrelated to mouse lag on other systems. The 08 or 20 patch might make a difference for non-Win8 systems.

User avatar
JeanNYGUARD
Lieutenant-Junior Grade
Lieutenant-Junior Grade
Posts: 52
Joined: Fri Dec 12, 2008 3:00 am

Re: BOTF Lag

Post by JeanNYGUARD » Sun Jan 13, 2013 5:25 am

I noticied the lag stops when I CNTL ALT DELETE, then go back into the game. It comes back maybe a few seconds later, maybe a few minutes later.

User avatar
Awaken
Cadet 1st Year
Cadet 1st Year
Posts: 4
Joined: Fri Oct 24, 2008 2:00 am

Re: BOTF Lag

Post by Awaken » Mon Apr 01, 2013 9:11 am

Try MPR++ , totally eliminated mouse lag for me, and it's running flawlessly in Windows 8, without even compatibility mode - except it crashes on launch when I have my extra monitors enabled, lol. Played 800 turns (in ECM large!) this weekend without a single crash, and the usual slowdown over time and mouse lag I've come to expect from botf :)

https://www.armadafleetcommand.com/onscr ... ls&lid=196

Oh, also works fine with the 1024 patch(s).

User avatar
nx2000
Cadet 2nd Year
Cadet 2nd Year
Posts: 6
Joined: Fri Jun 14, 2013 9:08 pm

Re: BOTF Lag

Post by nx2000 » Thu Jun 27, 2013 1:29 pm

When this starts to happen bad, I found that saving the game and immediately loading it will reset the memory. The lag goes away. I have to do this every 20 turns or so once the game gets moving.

Post Reply

Return to “General Modding Information/Questions”

Who is online

Users browsing this forum: No registered users