MPR++ Vanilla crashes on startup on Windows 10 x64

MPR++; support/discussion/questions

Moderator: thunderchero

User avatar
Snapper9
Cadet 3rd Year
Cadet 3rd Year
Posts: 11
Joined: Sun Aug 29, 2010 2:00 am

MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Snapper9 » Tue Dec 26, 2017 6:02 pm

Damn. An error occured during startup. The game just crashes during startup. I once had a version that "worked out of the box" on Win 7. Now, I use Win 10 and it doesn't work. I commented the ini-entry RTSS, but that didn't help.

The setup process seems to be going through properly, though.

Edit: When starting the game, the game seems not to try to start in fullscreen mode, a windows does appear instead and then it crashes with an error message just saying it crashed.

Any suggesstions?

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 5705
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by thunderchero » Tue Dec 26, 2017 8:59 pm

try starting from trek.exe from install path

User avatar
Snapper9
Cadet 3rd Year
Cadet 3rd Year
Posts: 11
Joined: Sun Aug 29, 2010 2:00 am

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Snapper9 » Wed Dec 27, 2017 6:55 am

That's what I already tried. :(

I know it is difficult to give tips with this little information. But please, try it nevertheless. Need this game running. :grin:

At least it doesn't seem to be an issue with DirectX or Visual Compiler.

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2514
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Flocke » Wed Dec 27, 2017 7:39 am

Assuming you installed the included directx and vc_redist, is there any more info e.g. in the mpr++/ogre.log that might give a clue?
In full editor view there is an "Attachments" button below the text box you could use to attach files to your post.

Did you make any modifications to the game prior to installing mpr++?
Pretty hard to guess what caused the crash with the short info you gave, but when you just want to get a botf game rolling, try reinstall without mpr++ and just use dxwnd. :wink:

User avatar
Snapper9
Cadet 3rd Year
Cadet 3rd Year
Posts: 11
Joined: Sun Aug 29, 2010 2:00 am

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Snapper9 » Wed Dec 27, 2017 8:31 am

Ok, nice hint.

As I found out, the same error occurs with a 32 bit version of Windows Vista.

I don't install anything else except "BOTF All in one 1.0.1" and MPR++.

I added the file you mentioned (what ever this file is) to this post.

Edit: Ignore me and my problem if I'm annoying. I do not want to spoil your free time. :wink:
Attachments
ogre.log
(25.19 KiB) Downloaded 7 times

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2514
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Flocke » Wed Dec 27, 2017 1:39 pm

Nah, you are far from annoying, such pesky issues occure and it's always great to figure it out if we can.

That file is a log for the ogre3d graphics engine initialization, but there are no errors logged.
The only thing of notice I found in there is that your system has a pretty low spec Celeron 1,6GHz and an integrated Intel HD Graphics GPU.
In case you didn't correctly disable RTSS that would be an explanation.

I guess in the mpr++ log there's no error logged either.
Of interest however would be the exact error message and what offset the application crashed if listed. For detailed info on the crash you could check the windows event log ( in system control -> management -> event log ). In windows protocols -> applications all the application crashes should be listed.

In the main botf folder, does there occure any crash.log possibly?
And does botf work without mpr++?

User avatar
Snapper9
Cadet 3rd Year
Cadet 3rd Year
Posts: 11
Joined: Sun Aug 29, 2010 2:00 am

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Snapper9 » Wed Dec 27, 2017 3:58 pm

The mentioned computer specs are correct. I tried with RTSS disabled, but nothing changed. The Windows error protocoll doesn't give any answers, nevertheless I adde a screenshot of it. I did so to for the mpr++ log file. There is an error log file within the Vanilla directory, but it's empty.
From tomorrow on I'll be on a journey and will not be available for the rest of the year. I'll report back as soon as I'm back in the new year.
Attachments
2017-12-27 20_49_26.png
2017-12-27 20_49_26.png (74.44 KiB) Viewed 249 times
mpr++.log
(1.29 KiB) Downloaded 7 times

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 5705
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by thunderchero » Wed Dec 27, 2017 4:25 pm

Flocke wrote:
Wed Dec 27, 2017 1:39 pm
And does botf work without mpr++?
I second this question, if same error, it is not an mpr++ issue. have you ever played botf on this system?

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2514
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Flocke » Wed Dec 27, 2017 5:06 pm

Snapper9 wrote:
Wed Dec 27, 2017 3:58 pm
The Windows error protocoll doesn't give any answers, nevertheless I adde a screenshot of it.
There is more info to it than you might think. It gives the exact crash location in the code, the error offset 0x00090245 plus the windows exception code 0xc0000005, an access violation e.g. caused by dereferencing a null pointer.

The error offset can both be used to search the forums for whether other people encountered the same crash and for people knowing a bit of assembler debugging to check the assembler code for where it exactly crashed.
Further it tells trek.exe crashed, not the mpr++.dll module itself so it is likely not the mpr++ rendering which fully happens in the mpr++.dll module but either a broken botf vanilla install, or a broken mpr install that patched the wrong trek.exe offsets, which can happen when trek.exe got modified or when the installer itself is broken.

Anyhow, wish you a good journey and see you back in the next year!
Gosh, another year that already passed...
Last edited by Flocke on Wed Dec 27, 2017 5:13 pm, edited 1 time in total.

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2514
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Flocke » Wed Dec 27, 2017 5:11 pm

Here, someone that encountered a crash in same location: viewtopic.php?f=29&t=2692&p=43640&hilit=00090245#p43640 ;)

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 5705
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by thunderchero » Wed Dec 27, 2017 9:51 pm

Flocke wrote:
Wed Dec 27, 2017 5:06 pm
the error offset 0x00090245
that location is a sound subsection, so it might help to turn sound off in stbof.ini

if that helps or you may want to try other available Mss32.dll's

User avatar
Flocke
BORG Trouble Maker
BORG Trouble Maker
Posts: 2514
Joined: Sun Apr 27, 2008 2:00 am
Location: Hamburg, Germany
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Flocke » Thu Dec 28, 2017 3:05 am

thunderchero wrote:
Wed Dec 27, 2017 9:51 pm
that location is a sound subsection, so it might help to turn sound off in stbof.ini
Yeah, it's the assembler offset from the memory load address, so assembler offset 0x490245 actually if I'm correct.
There is some padding ahead not visible by ida that I got confused on before.
0x491245 wouldn't make any sense given it's in the middle of an instruction.

Checking the ida database 0x490245 is in Sound_X_490180 loading some sound right after a call to DoUnzip_LoadFile.
So it's rather not an issue with the sound driver playing the sound, but a load issue unzipping the sound, which does match the issue reported by Vulgarny I linked above.
For him it broke when he used winrar instead of UE to manually modify stbof.res

User avatar
Snapper9
Cadet 3rd Year
Cadet 3rd Year
Posts: 11
Joined: Sun Aug 29, 2010 2:00 am

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Snapper9 » Thu Dec 28, 2017 7:15 am

I got the time to post one last message befor I leave. Unfortunatly I forgot to mention: without MPR++ Botf runs, but on the Windows 10 system it runs with extreme mouse lags. On the Windows Vista system it runs perfectly without those lags. I read somewhere about mouse lags but didn't find any solution for it.

I had a previous MPR++ version one year ago or so. That worked perfectly on Win 10. As I remember I didn't have to install anything except MPR++ (like BotF itself). like I do now.

Deactivating sound within the stbof.ini didn't help. Again I did not modify anything but installed the vanilla versions as well of BotF as of MPR++. On my system 7Zip and 8Zip are installed. But I think that isn't an issue, bacaus BotF and/or MPR++ use their own archivers.

Have a good New Year!

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 5705
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by thunderchero » Thu Dec 28, 2017 8:10 pm

now I am really confused, my next suggestion would be;

1. uninstall mpr++
2. re-download mpr++ installer (be sure to only use standard MPR++ version "MPR++_demo_installer_0.2.6c.exe"
3. Do not use "1024_MPR++_demo_installer_0.2.6c.exe" if you want higher res, install though res option in All in one installer.
4. install "MPR++_demo_installer_0.2.6c.exe" and re-test
Snapper9 wrote:
Thu Dec 28, 2017 7:15 am
without MPR++ Botf runs, but on the Windows 10 system it runs with extreme mouse lags. On the Windows Vista system it runs perfectly without those lags. I read somewhere about mouse lags but didn't find any solution for it.
DxWnd will fix mouse lag. install tools form All in one installer then select option for fullscreen or windowed depending on what you want. Note tools/dxwnd must be installed before any version (vanilla or mod) to set shortcut command lines properly.

Note; DxWnd and MPR++ should not be used at same time due to conflicts. when MPR++ is installed you must start game using the trek.exe in install path not the shortcuts or start menu
Snapper9 wrote:
Thu Dec 28, 2017 7:15 am
I had a previous MPR++ version one year ago or so. That worked perfectly on Win 10. As I remember I didn't have to install anything except MPR++ (like BotF itself). like I do now.
MPR++ has always required vanilla and mods installed before installing MPR++.

User avatar
Snapper9
Cadet 3rd Year
Cadet 3rd Year
Posts: 11
Joined: Sun Aug 29, 2010 2:00 am

Re: MPR++ Vanilla crashes on startup on Windows 10 x64

Post by Snapper9 » Thu Jan 04, 2018 8:13 am

I'm back from my journey and wish you a new year.

Well, that did the trick. I used the 1024-version, that was the fault. The game is working now. But it is difficult for me to get the game run in fullscreen mode instead of window mode, although I made the correct choice during the install process.

Is there a way to choose which resolution and/or display mode to use every time I start the game? I checked the dxwnd-settings as you can see on the screenshot, but the settings should be ok.

I'll go on to try and I'll report back soon in either case successfull or not.

By the way, after installing both the All in One Installer and MPR++ I have only one link on the desktop and one in the Windows Start Menu. Both of them link to the following folder: "I:\Games\Birth of the Federation\Vanilla\trek.exe" This is exactly the trek.exe I'd start if I start the game "directly" as you recommended. So this never was an issue.

Is it correct: As soon as MPR++ is installed there is no way to use the dxwnd-version of the game untill I completely uninstall BotF and reinstall the All in One Installer without MPR++?

I'm sorry for beeing totally confused and overburdened with the install process. :( It is nice to have at least you both, guys. :)

Edit: As I recognize now, the game runs as expected when I don't install MPR++ afterwards. Any issue is fixed now. (And I am happy. I'm just still wondering, what MPR++ is good for. :))
Attachments
dxwnd settings.png
dxwnd settings.png (16.81 KiB) Viewed 108 times

Post Reply

Return to “MPR++”

Who is online

Users browsing this forum: No registered users and 3 guests