Game does not start after launch

Moderator: thunderchero

Forum rules
Please read the topic titles below to see if your issue matches already solved issues before creating new support ticket.
Post Reply
User avatar
smallaxe0217
Ensign
Ensign
Posts: 24
Joined: Thu Aug 21, 2008 2:00 am

Game does not start after launch

Post by smallaxe0217 » Sun Mar 17, 2019 1:56 am

Windows Version: Windows 10, X64
Video card/chip info: Intel HD Graphics
Are you useing DxWnd?: DxWnd Fullscreen
Was Birth of the Federation running on this system prior to this install No
List any crash logs or messages you might have seen
No crash logs appeared.

What have you already tried to solve the problem?
Uninstalled and reinstalled All-In-One.

Detailed description of your issue
I installed BOTF All in one on my Dell Inspiron 15 5000 series laptop, and tried to play the Vanilla version. The screen loads fine in fullscreen, I can select the starting options and civilization. However, when I click "start game", it goes to the "Game Loading" page full-screen, then changes to a Game-Loading page windowed in the left corner, freezes for a while, and then shuts down without starting the game. I installed the software on a different Windows 10 computer (desktop) and it works fine there, so I'm not sure what's happening here.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Game does not start after launch

Post by thunderchero » Sun Mar 17, 2019 8:36 am

It sounds like your Dell Inspiron 15 5000 does not support the install resolution you might try a lower resolution or dxwnd windowed

You might also try the Universal 1920 x 1080 (this is only available for a few mods and vanilla)
https://www.armadafleetcommand.com/get- ... le_id=1949

good luck and let us know if that does not fix issue

thunderchero

User avatar
smallaxe0217
Ensign
Ensign
Posts: 24
Joined: Thu Aug 21, 2008 2:00 am

Re: Game does not start after launch

Post by smallaxe0217 » Sun Mar 17, 2019 1:27 pm

I tried the Windowed version and kept it at the original 800*600, it still crashed after starting the game. The 1080 patch did not work for me either in my first instance or in this second instance. For the first instance, I wasn't able to select ANYTHING when the start-up screen appeared, and for the second instance the resolution was really poor and it still crashed anyways. Any other suggestions, or is it just incompatible with the laptop?

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Game does not start after launch

Post by thunderchero » Sun Mar 17, 2019 1:44 pm

1. install DirectX 9 redist this does not change your current version of directx. It will only add any files that is not on your system.

2. You may need to set up custom game settings in your Intel Graphics Control Panel (turn most features off) but this is trial and error.

User avatar
smallaxe0217
Ensign
Ensign
Posts: 24
Joined: Thu Aug 21, 2008 2:00 am

Re: Game does not start after launch

Post by smallaxe0217 » Sun Mar 17, 2019 8:04 pm

I installed the DirectX 9, same result. I may try to shift the settings on the Intel Graphics chip, but it does seem very touchy to do so. I will keep trying...

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Game does not start after launch

Post by thunderchero » Sun Mar 17, 2019 9:31 pm

the way you describe issue, (Loading page windowed in the left corner) it still sounds like a resolution not supported.

I suggest you confirm your adapter supports resolution you installed for BOTF or re-install at supported resolution.

this can be done by;
select 'PC settings"
select "system"
on "display" page at bottom select "Advanced display settings"
in new window select "Display Adapter properties"
in new window on adapter tab select "list all modes"
it should look like this
modes.jpg
modes.jpg (84.37 KiB) Viewed 669 times
look for;
800 by 600, true color (32 bit) 60 hertz
1024 by 768, true color (32 bit) 60 hertz
1366 by 768, true color (32 bit) 60 hertz
1920 by 1080, true color (32 bit) 60 hertz

60 Hertz maybe required but not sure myself?

keep us updated on your progress

User avatar
smallaxe0217
Ensign
Ensign
Posts: 24
Joined: Thu Aug 21, 2008 2:00 am

Re: Game does not start after launch

Post by smallaxe0217 » Fri Mar 22, 2019 7:44 am

I checked, and the required listings are there. I did note that my laptop has 48 hertz and 60 hertz for the listed resolutions, but not 75 hertz.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Game does not start after launch

Post by thunderchero » Fri Mar 22, 2019 8:55 am

1. have you re-downloaded all in one installer on dell laptop? (most corrupt downloads will not allow installer to complete, but it has happened before)

2. check your windows "event viewer" (re-create crash so error will be at top of list) the crash should have a log there with "Faulting application path" and "Fault offset" this might help narrow down error. here is an example of "event viewer" Faulting application path and Fault offset is only info I need.

log will be in "windows logs" tab "application" as shown
event.jpg
event.jpg (286.86 KiB) Viewed 638 times

User avatar
smallaxe0217
Ensign
Ensign
Posts: 24
Joined: Thu Aug 21, 2008 2:00 am

Re: Game does not start after launch

Post by smallaxe0217 » Sat Mar 30, 2019 9:28 pm

1. I re-downloaded and re-installed many times. I used the same download file to install BOTF on another PC and it works fine there.

2. I did as you said for event viewer, and here are the results as asked for:

Faulting application path: C:\botf\Vanilla\trek.exe
Fault offset: 0x00033030

There were actually two error reports there, as it seems it gave that error for the full screen, and then repeated it for the windowed attempt.

User avatar
thunderchero
Site Administrator aka Fleet Admiral
Site  Administrator aka Fleet Admiral
Posts: 6073
Joined: Fri Apr 25, 2008 2:00 am
Location: On a three month training mission, in command of the USS Valiant.
Contact:

Re: Game does not start after launch

Post by thunderchero » Sat Mar 30, 2019 9:59 pm

I am running out of suggestions the offset from event viewer leads to a AI raid sub section, so I see no help/insight there.

but my last suggestion;
if both laptop and desktop uses default install location (C:\botf\Vanilla\)
1. move or delete laptop "vanilla" folder from C:\botf\
2. on desktop copy "vanilla" folder from C:\botf\ and transfer to laptop C:\botf\
3. test and keep finger crossed

Post Reply

Return to “Submit a support ticket for Windows (all versions)”

Who is online

Users browsing this forum: No registered users