explorer III

Supremacy; support/discussion/questions

Moderators: thunderchero, Iceman

Post Reply
User avatar
kaiidth
Cadet 1st Year
Cadet 1st Year
Posts: 4
Joined: Tue Dec 10, 2019 5:09 pm

explorer III

Post by kaiidth » Tue Dec 10, 2019 5:26 pm

Hi,

Recently, I discovered Star Trek Supremacy. First of all: my compliments to the makers for this successor for BOTF.
I have also a question. When I play as the Federation with a tech level 'early' or 'developed' and I reach the level that I could build the explorer iii, I can't build it. At the same time, the explorer II has also been vanished from the building options.

Perhaps I have overlooked somethting, but could anyone help me?

Thank you in advance.

Iceman
Rear-Admiral
Rear-Admiral
Posts: 1551
Joined: Fri Apr 10, 2009 2:00 am

Re: explorer III

Post by Iceman » Tue Dec 10, 2019 5:50 pm

Hi kaiidth, welcome to the forums, and thanks!
Hmm, you raise a valid point there. The Explorer III obsoletes the Explorer II (so once you get to III you cannot build IIs anymore), BUT, the Explorer III can only be built on a Fleetyard (which you can only build on Sol)...
We might have to lower the tech requirements of the Explorer III, as the Shipyard III only allows building ships up to TL11.

Good catch! Thanks!
Hope you're having fun with the game, in spite of this. :wink:

User avatar
kaiidth
Cadet 1st Year
Cadet 1st Year
Posts: 4
Joined: Tue Dec 10, 2019 5:09 pm

Re: explorer III

Post by kaiidth » Thu Dec 12, 2019 3:29 pm

Thank you iceman. Wouldn't it be an option, that only the Fleet Yard can build explorer III, while the explorer II will remain available for the shipyard III?

Iceman
Rear-Admiral
Rear-Admiral
Posts: 1551
Joined: Fri Apr 10, 2009 2:00 am

Re: explorer III

Post by Iceman » Thu Dec 12, 2019 3:42 pm

That's easy enough to do. It's a matter of the Explorer III not obsoleting the Explorer II.
If you want a quick fix for that, edit the \Data\TechObjectDatabase.xml file (preferably with Notepad++) and remove lines 21897~21899. Those should be:

Code: Select all

      <ObsoletedItems>
        <ObsoletedItem>FED_COMMAND_SHIP_II</ObsoletedItem>
      </ObsoletedItems>
If you're not comfortable with doing that, LMK and I'll post the file here as an attachment.

This problem is not exclusive to the Feds though, it happens for all majors.
I might lower the TL reqs for all Command ships of all majors by one. And Strike Cruisers too.

Post Reply

Return to “Supremacy”

Who is online

Users browsing this forum: No registered users